Closed Bug 1296735 Opened 5 years ago Closed 5 years ago

Unable to run xpcshell unittest from one click loaner

Categories

(Testing :: Mozbase, defect)

defect
Not set
normal

Tracking

(firefox51 fixed)

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: jmaher, Assigned: ahal)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I have a failure I would like to reproduce, so I get a loaner and choose option #2 (setup and give me a shell).

This works great and gives me a prompt, I do:
mach xpcshell-test <dir>

and it finds the correct xpcshell.ini, but gives me:
(venv)root@taskcluster-worker:~# 
(venv)root@taskcluster-worker:~# mach xpcshell-test uriloader/exthandler/tests/unit/test_handlerService.js
 0:00.22 LOG: MainThread INFO Found node at /usr/local/bin/node
 0:00.22 LOG: MainThread INFO Found moz-http2 at /home/worker/workspace/build/tests/xpcshell/moz-http2/moz-http2.js
 0:01.15 LOG: MainThread ERROR no tests to run using specified combination of filters: skip_if, run_if, fail_if, pathprefix([u'/home/worker/workspace/build/tests/xpcshell/tests/uriloader/e
xthandler/tests/unit/test_handlerService.js'])
 0:01.16 LOG: MainThread INFO Running tests sequentially.
 0:01.16 SUITE_START: MainThread 0
 0:01.16 LOG: MainThread INFO Node moz-http2 server shutting down ...
 0:01.16 LOG: MainThread ERROR No tests run. Did you pass an invalid --test-path?
 0:01.16 LOG: MainThread INFO INFO | Result summary:
 0:01.16 LOG: MainThread INFO INFO | Passed: 0
 0:01.16 LOG: MainThread INFO INFO | Failed: 1
 0:01.16 LOG: MainThread INFO INFO | Todo: 0
 0:01.16 LOG: MainThread INFO INFO | Retried: 0
 0:01.16 SUITE_END: MainThread 
Summary
=======
Ran 0 tests
Expected results: 0
Unexpected results: 0


this is bizarre because I have a valid xpcshell.ini file with valid tests.  In the above example I am trying to run a single specific test with no luck
Blocks: 1262260
Summary: unable to run xpcshell unittest from one click loaner → Unable to run xpcshell unittest from one click loaner
Sorry, looks like I regressed this with a previous patch. The main problem is that the xpcshell harness can't handle absolute paths. You can also reproduce this locally by running |mach xpchsell-test <absolute path>|.

So the regression is that I started normalizing test paths to be absolute. But the better fix is to make the xpcshell harness handle absolute paths in the first place. I'll come up with a patch shortly.
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Turns out the best place to fix this is actually in manifestparser.
Component: General → Mozbase
Product: Taskcluster → Testing
Comment on attachment 8783647 [details]
Bug 1296735 - [manifestparser] pathprefix filter should use absolute paths if the filter is also absolute,

https://reviewboard.mozilla.org/r/73376/#review71154

good find
Attachment #8783647 - Flags: review?(jmaher) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/279f5c243c49
[manifestparser] pathprefix filter should use absolute paths if the filter is also absolute, r=jmaher
https://hg.mozilla.org/mozilla-central/rev/279f5c243c49
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.