Browser hangs using jre 1.3.1_02

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P1
major
VERIFIED FIXED
17 years ago
8 years ago

People

(Reporter: Paul Wyskoczka, Assigned: James.Melvin)

Tracking

({hang, topembed+})

Trunk
x86
Windows 98
hang, topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: jpibug)

(Reporter)

Description

17 years ago
Seen on windows with RTM 6.01, 6.1, and 6.2.1

If you click directly on the links below here, it sometimes hangs, but not 
always.
http://java.sun.com/applets/other/Bullets/alphabullet.html
http://java.sun.com/applets/other/Bullets/huebullet.html
http://java.sun.com/applets/other/Bullets/dukebullet.html

If you go to this url: http://java.sun.com/applets/
then look for the title "other applets", then click on the link "Bullets", it has
"AlphaBullet, HueBullet, and Duke Mascot". Click one of those links, it always
hangs!!! Actually, that also links you to the same full links above though.

Another instance of a hang

Seen on windows with RTM 6.01, 6.1, and 6.2.1 (jre 1.3.1_02)

1. Launch the above build (e.g.rtm 6.2.1)
2. Go to this url: http://google/search?q=java+applet+test&hl=en&lr=
3. Currently, there're two "Java Applet Test".  Click on the first link,
   it hangs! The link of the first one is:
http://www.kobe-yamate.ac.jp/~nagasm/java/javaroom/Wireframe/sample.html
4. Restart the browser. Click on the second link, it also hangs too.
The second link is:
http://www.kobe-yamate.ac.jp/~nagasm/java/javaroom/Molecule/sample.html

Comment 1

17 years ago
Steve, 
Anything change in the update that could cause this?

Comment 2

17 years ago
Don't know.  Our group doesn't handle the _XX releases.  I'll forward this
question on to the folks who do.

Comment 3

17 years ago
with 1.4.0 the page takes forever to load. No hang just really really long load
time.

Comment 4

17 years ago
wfm using build 2002030803 on Win2k + JRE 1.4.0

Comment 5

17 years ago
(1) Using jre 1.40 with RTM 6.2.1, it takes so long to load it. I tried 20 times, 
and it hung 2 times. 
http://java.sun.com/applets/other/Bullets/huebullet.html
Make sure to click 'reload, back, forward' buttons for many times to see
it hangs (if you get lucky).

(2) If the browser hangs, the bookmark of the above url get lost. Also,
the profile got corrupted it because once you relanuch the browser using 
that profile, the browser hangs and need to reboot the machine for several time
and it still not work.

(3) Use the "new profile" then it relaunches fine again.

Comment 6

17 years ago
I used windows 98.

Comment 7

17 years ago
WFM with Sun's jre 1.4.0rc on RedHat 6.2

BTW, i got hang on one of these pages with Netscape 4.x and Sun's 1.3.1 plugin 
 -> likely to by pure [jpibug]

Comment 8

17 years ago
This has been files in Sun's bug tracking system.

Bugtraq: 4657759

Comment 9

17 years ago
I looked the bug on JRE 1.4.x and could reproduce it. The bottleneck appears in 
the Java native call into native windowing system, such as create native window 
and set position, etc.

And there is an interesting behavior. Start Mozilla browser -> start Microsoft 
Spy + -> Find browser window and monitor its message -> go to the testing URL

and the bottleneck disappears.

Comment 10

17 years ago
http://bugscape.netscape.com/show_bug.cgi?id=12953
Keywords: edt0.9.9, topembed

Comment 11

17 years ago
OK, the Bugscape Bug mentioned above by mdunn is distinct from the problem at
hand.  The Bugscape Bug above (Bugscape 12953) mentions a hang on iPix applets,
which could well be caused by the IBM Byte Code Optimizer rathole (also
documented in bug 85710 ).

Updated

17 years ago
Keywords: edt0.9.9, topembed → topembed+

Comment 12

17 years ago
I think this problem is related to message loop. Starting an applet is much 
slower with Mozilla, but whenever you use Spy ++ to spy the browser window's 
client area, will speed up the applet.

Mozilla people, please comment this behavior.

Thanks

Comment 13

17 years ago
Zhengyu, why does 1.3.1_02 and later show this problem, but NOT previous JREs? 
For example, 1.3.1 doesn't show this problem, and I think 1.3.0_01 doesn't show
this problem.  I'm not denying that Mozilla could have a problem, but could you
explain why older JREs don't show this problem, but only newer ones?

Comment 14

17 years ago
I would like to add : The same mozilla build from 2 months ago which works fine 
with jre1.3.1 stops working when jre1.3.1 is removed and jre 131_02 is installed
and used.

Comment 15

17 years ago
I am taking a look at this now.

Comment 16

17 years ago
A work around has been implemented in JRE 1.4.1 to fix the problem, may back 
port to JRE 1.3.x.

Updated

16 years ago
Blocks: 142810

Comment 17

16 years ago
also hangs on windows 98,(branch build: 2002-05-15-08-1.0.0) and 
(2002-05-12-20-XX-PR1) with the following url:
http://www.mozilla.org/quality/browser/front-end/testcases/oji/test10.html

Updated

16 years ago
Keywords: hang

Comment 18

16 years ago
I forgot to mention the version of jre. I used JRE 1.4.0_01.

Comment 19

16 years ago
The browser was also hung when running IE, going to:
http://www.mozilla.org/quality/browser/front-end/testcases/oji/test10.html.

So far, it seems the test case only runs OK on Solaris, which runs with a later
version of JRE 1.4 (later than the one downloading for Windows and Linuxs).
Trying to get a new version of JRE to test on Windows and Linux, to see if that
fix the problem.

Comment 20

16 years ago
Tried with JRE 1.4.1 beta, the applets seemed loaded, but no "dancing" letters.
The pr0blem seemed not fixed completely in JRE 1.4.1.
Re-assign to jim's Java plugin group.


Assignee: joe.chou → James.Melvin
Whiteboard: jpibug

Comment 21

16 years ago
I tested dancing letters applet with 1.4.1 beta b13, could not reproduce the 
problem. 

Joe, can you confirm that?

Comment 22

16 years ago
I tried the test case on comment #17 with ns7pr1 and JRE 1.4.1 b11. Still could
not see the dancing charictors in the applets (except the first largest one). 
Tried to install JRE1.4.1 b14 (the only one I could find in Sun's internal
server), but had trouble in the installation (kept getting errors). 
Zhangyu, if you verify that the problem has been fixed, then mark it fixed in
1.4.1, and QA will test it when 1.4.1 becomes available to the public.

Comment 23

16 years ago
Add Zhangyu to the cc list.

Comment 24

16 years ago
Tried the test case in comment #17 with JRE 1.4.1 b13, still could not see the
dancing letters in the applets, except the first one. The result is the same as
JRE 1.4.0_01. Did not seem to see the work-around's impact.

Zhangyu, did you try the test case in comment #17? If so, did you see the
dancing letters in all the black rectengles, besides the first one?

Updated

16 years ago
Priority: -- → P1

Comment 25

16 years ago
Joe, Jim and I all tested 
http://www.mozilla.org/quality/browser/front-end/testcases/oji/test10.html, it 
worked fine.

Comment 26

16 years ago
Based on comment #25, resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 27

16 years ago
Windows 2000 (netscape branch build: 2002-08-07-08-TRUNK)

(1) Jre 1.4.1 fixes the problem on comment #25, it loads quick without hanging,
also, all the dancing letters appear in all the black rectangles, but using jre
1.4.0_01, it sometimes hangs or loads very slow, and the dancing letters seem to
appear only the first one.

(2) Using jre 1.4.1 and run those urls below, it loads very quick.
http://java.sun.com/applets/other/Bullets/alphabullet.html
http://java.sun.com/applets/other/Bullets/huebullet.html
http://java.sun.com/applets/other/Bullets/dukebullet.html



Status: RESOLVED → VERIFIED

Comment 28

16 years ago
Oops, I enter the wrong build.
It should be windows 2000 (netscape branch build: 2002-08-07-08-1.0)

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.