Status

()

defect
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: mrrrgn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

3 years ago
The problem seems to be related to recently added changes in Unicode.cpp. We should start by rolling back those changes, and then add our own test to detect the issue.
Reporter

Comment 1

3 years ago
Sure enough, backing out fixes the test. This patch is just a start. Still investigating the root causes / a better fix.
Attachment #8783184 - Flags: review?(efaustbmo)
Reporter

Comment 2

3 years ago
Attachment #8783185 - Flags: review?(efaustbmo)
Comment on attachment 8783184 [details] [diff] [review]
bad-unicode-1.diff

Review of attachment 8783184 [details] [diff] [review]:
-----------------------------------------------------------------

r=me so long as this is a straight backout.
Attachment #8783184 - Flags: review?(efaustbmo) → review+
Comment on attachment 8783185 [details] [diff] [review]
bad-unicode-2.diff

Review of attachment 8783185 [details] [diff] [review]:
-----------------------------------------------------------------

r=me for a straight backout.
Attachment #8783185 - Flags: review?(efaustbmo) → review+

Comment 6

3 years ago
For reference: http://rawgit.com/es-shims/es6-shim/master/test/ and http://rawgit.com/es-shims/es5-shim/master/tests/ can be used to detect it, and the issue is around which characters are recognized as whitespace.
As long as this test [1] expects U+180E to be a white space character, the es6-shim test suite will fail when we update to Unicode 6.3 (or newer).

[1] https://github.com/es-shims/es6-shim/blob/master/test/number.js#L469

Comment 8

3 years ago
As Unicode updates invalidate my shim tests, I'll modify them to adapt or ignore :-) I brought this to efaust's attention to verify whether this was a correct failure, or a bug.
We landed the same change in bug 1318403 again. The es6-shim test is incorrect.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 11

2 years ago
More precisely, the es6-shim test is correct for ES6 - Unicode version updates in later editions of the ES spec have invalidated the previously correct tests :-)
You need to log in before you can comment on or make changes to this bug.