Feature request : please add a about:config option for enabling a save as file browsing dialog.

UNCONFIRMED
Unassigned

Status

()

Firefox for Android
General
P3
enhancement
UNCONFIRMED
2 years ago
a year ago

People

(Reporter: ytrezq, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; Trident/7.0; rv:11.0) like Gecko Presto/2.12.378 Opera/12.50
Firefox for Android

Steps to reproduce:

Try to save an mp4 file that is without the correct content‑type header. This is the wanted behaviour since the file is copyrighted media that was forgot there.


Actual results:

Firefox didn’t honored the download= attribute of the <a> element I build. As a result the mp4 video was stoping each 30s because my connection is too slow for watching. 

There’s no way to save it to my ꜱᴅ card directly http://android.stackexchange.com/q/154170/87784


Expected results:

As detailed on https://support.mozilla.org/fr/questions/792670 this the wanted behaviour to avoid confusing the dumb user.

Add‑ons proposing the save as functionality don’t let me to browse and select the target folder (and of course by design too they can’t)

So what about having this feature existing but disabled by default ? The only way to enable it would be to use an option in about:config

Or as an alternative, no longer require the write permission to the ꜱᴅ card since nothing can be written to ꜱᴅ card.
(Reporter)

Updated

2 years ago
Severity: normal → enhancement
OS: Unspecified → Android
(Reporter)

Updated

2 years ago
Hardware: Unspecified → All

Updated

2 years ago
Component: Untriaged → General
Product: Firefox → Firefox for Android
(Reporter)

Comment 1

2 years ago
Currently, the way to download to ꜱᴅ card is very user unfriendly, bacuse https://support.mozilla.org/en-US/questions/978679 needs to performed each time the target folder needs to be changed

and this doesn’t let to browse files before doing it.
Firefox has supported <a href="foo" download> since Firefox 20. https://developer.mozilla.org/en-US/docs/Web/HTML/Element/a#Attributes

Android does not ship with a file browser. about:config is not intended for general use.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
Created attachment 8785510 [details]
Screenshot_2016-08-27-01-53-08.png

(In reply to Kevin Brosnan [:kbrosnan] from comment #2)
> Firefox has supported <a href="foo" download> since Firefox 20.
> https://developer.mozilla.org/en-US/docs/Web/HTML/Element/a#Attributes
> 
> Android does not ship with a file browser. about:config is not intended for
> general use.

Disagree, the download attribute doesn’t work for mp4 files served without the required ʜᴛᴛᴘ headers for downloading.

However, you’re right with the file browser. I admit I got confused with the feature of opera mini and chrome. See the screenshots. They really look a true file browser.
So firefox would needs to implement it’s own browsing part that allow to create folders rename files etc…
But again this isn’t something that can be done at the add‑ons level… not with the current ᴀᴘɪ for android.
Flags: needinfo?(kbrosnan)
(Reporter)

Updated

2 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

2 years ago
Created attachment 8785511 [details]
Screenshot_2016-08-27-01-54-17.png
(Reporter)

Comment 5

2 years ago
Created attachment 8785512 [details]
Screenshot_2016-08-27-01-56-33.png
(Reporter)

Comment 6

2 years ago
Created attachment 8785513 [details]
Screenshot_2016-08-27-01-57-44.png
(Reporter)

Comment 7

2 years ago
Created attachment 8785514 [details]
Screenshot_2016-08-27-01-59-48.png
(Reporter)

Updated

2 years ago
Summary: Feature request : please add a about:config option for restoring a save as dialog. → Feature request : please add a about:config option for restoring a save as file browsing dialog.
(Reporter)

Updated

2 years ago
Summary: Feature request : please add a about:config option for restoring a save as file browsing dialog. → Feature request : please add a about:config option for enabling a save as file browsing dialog.
(Reporter)

Updated

2 years ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.