Intermittent toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | xpcshell return code: 0 | test_stderr - [test_stderr : 467] Saw second line of stderr output on the console - -1 != -1

RESOLVED DUPLICATE of bug 1295867

Status

WebExtensions
Untriaged
RESOLVED DUPLICATE of bug 1295867
2 years ago
a day ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #1291199 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=33947684&repo=mozilla-inbound

12:06:20     INFO -  TEST-PASS | toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | test_child_process - [test_child_process : 431] Received one command line argument - 2 == 2
12:06:20     INFO -  TEST-PASS | toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | test_child_process - [test_child_process : 432] Command line argument is the path to the native host manifest - "c:\\\\users\\\\cltbld~1.t-w\\\\appdata\\\\local\\\\temp\\\\xpc-profile-gsrvph\\\\tmp\\\\NativeMessaging\\\\info.json" == "c:\\\\users\\\\cltbld~1.t-w\\\\appdata\\\\local\\\\temp\\\\xpc-profile-gsrvph\\\\tmp\\\\NativeMessaging\\\\info.json"
12:06:20     INFO -  TEST-PASS | toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | test_child_process - [test_child_process : 433] Working directory is the directory containing the native appliation - "c:\\\\users\\\\cltbld~1.t-w\\\\appdata\\\\local\\\\temp\\\\xpc-profile-gsrvph\\\\tmp\\\\NativeMessaging" == "c:\\\\users\\\\cltbld~1.t-w\\\\appdata\\\\local\\\\temp\\\\xpc-profile-gsrvph\\\\tmp\\\\NativeMessaging"
12:06:20     INFO -  (xpcshell/head.js) | test run_next_test 10 pending (2)
12:06:20     INFO -  (xpcshell/head.js) | test test_child_process finished (2)
12:06:20     INFO -  toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | Starting test_stderr
12:06:20     INFO -  (xpcshell/head.js) | test test_stderr pending (2)
12:06:20     INFO -  "Extension loaded"
12:06:20     INFO -  (xpcshell/head.js) | test run_next_test 10 finished (2)
12:06:20     INFO -  PROCESS | 5884 | ++DOCSHELL 0000005F3334E000 == 19 [pid = 5884] [id = 19]
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 55 (0000005F3334F800) [pid = 5884] [serial = 55] [outer = 0000000000000000]
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 56 (0000005F33350800) [pid = 5884] [serial = 56] [outer = 0000005F3334F800]
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 57 (0000005F33354800) [pid = 5884] [serial = 57] [outer = 0000005F3334F800]
12:06:20     INFO -  PROCESS | 5884 | ++DOCSHELL 0000005F3236C000 == 20 [pid = 5884] [id = 20]
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 58 (0000005F33315000) [pid = 5884] [serial = 58] [outer = 0000000000000000]
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 59 (0000005F3344AC00) [pid = 5884] [serial = 59] [outer = 0000005F33315000]
12:06:20     INFO -  PROCESS | 5884 | JavaScript strict warning: chrome://global/content/bindings/browser.xml, line 369: ReferenceError: reference to undefined property tabBrowser.localName
12:06:20     INFO -  PROCESS | 5884 | ++DOMWINDOW == 60 (0000005F3331FC00) [pid = 5884] [serial = 60] [outer = 0000005F33315000]
12:06:20     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property tabBrowser.localName" {file: "chrome://global/content/bindings/browser.xml" line: 369}]"
12:06:20     INFO -  PROCESS | 5884 | [5884] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file c:/builds/moz2_slave/m-in-w64-d-0000000000000000000/build/src/dom/base/nsContentUtils.cpp, line 6061
12:06:20     INFO -  "CONSOLE_MESSAGE: (info) stderr output from native app stderr: hello stderr"
12:06:20     INFO -  "CONSOLE_MESSAGE: (info) === console listener 0.5405160302047323 done ==="
12:06:20     INFO -  TEST-PASS | toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | test_stderr - [test_stderr : 466] Saw first line of stderr output on the console - 1 != -1
12:06:20  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js | test_stderr - [test_stderr : 467] Saw second line of stderr output on the console - -1 != -1
12:06:20     INFO -      C:/slave/test/build/tests/xpcshell/tests/toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js:test_stderr:467
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1295867
Keywords: intermittent-failure

Updated

a day ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.