Multibyte base DN is dislayed garbled, unable to connect

VERIFIED FIXED in mozilla1.0

Status

MailNews Core
LDAP Integration
P2
normal
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: ji, Assigned: Srilatha Moturi)

Tracking

({intl, regression})

Trunk
mozilla1.0
x86
Windows 2000
intl, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2])

Attachments

(2 attachments, 1 obsolete attachment)

13.44 KB, image/jpeg
Details
2.45 KB, patch
Jean-Francois Ducarroz
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Build: 03/08 win32

Ja base DN is displayed garbled on Edit window, unable to connect to the
directory with this base DN.

Steps to reproduce:
1. Open Edit | Preferences | Mail and Newsgroup | Addressing window.
2. Check on Directory Server.
3. Click on Edit Directories
4. Click on Add.
5. Enter a directory name and a mutibyte base DN like o=ネットスケープ, port set
to 8000, and click on OK button to save it. (view this page in Japanese
(Shift-JIS), and copy/paset the Ja base DN)
6. Select the newly created directory with the ja base DN and click on Edit,
   the Ja base DN is not displayed correctly.

Screenshot to follow.
(Reporter)

Comment 1

16 years ago
This is a serious regression from NS6.2.1, nominating for nsbeta1.
Keywords: intl, nsbeta1, regression
(Reporter)

Comment 2

16 years ago
Created attachment 73241 [details]
A screenshot.

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 3

16 years ago
This will be fixed by my patch in bug 124059

Comment 4

16 years ago
Discussed in Mail News bug meeting.  Decided to ADT2 this bug.
Whiteboard: [ADT2]

Comment 5

16 years ago
ji:
when will user put non ascii DN ? is this a common requirement for non ASCII
enterprise market ?

Comment 6

16 years ago
the patch in 124059 seems quite big. Is that possible we can produce a smaller
patch for THIS BUG and propose to be fixed earler than 124059 ?
(Reporter)

Comment 7

16 years ago
If the directory instance is created with a non-ASCII base DN, the client has to
provide this feature to be able to connect to this type of directory instances.
Base DN is the root of directory instance, it's very possible to have a
non-ASCII base DN if the company's name is non-ASCII. When I tested Directory
Server at Server team, supporting non-ASCII base DN is a requirement for
Directory Server.
(Assignee)

Comment 8

16 years ago
Created attachment 78594 [details] [diff] [review]
patch v1

changed the code such that we use getComplexValue and setComplexValue while
reading and writing the uri pref. Probably we will have to do the same for Ldap
pref migration code. Shirley is testing if that is broken too.
(Reporter)

Comment 9

16 years ago
Yes, 4.x pref migration is also broken. Tested with 04/10 trunk build and 4.75 Ja.
(Assignee)

Comment 10

16 years ago
Created attachment 78597 [details] [diff] [review]
patch v2 (includes fix for migration)
(Assignee)

Updated

16 years ago
Attachment #78594 - Attachment is obsolete: true
Comment on attachment 78597 [details] [diff] [review]
patch v2 (includes fix for migration)

R=ducarroz
Attachment #78597 - Flags: review+
Comment on attachment 78597 [details] [diff] [review]
patch v2 (includes fix for migration)

sr=sspitzer
Attachment #78597 - Flags: superreview+
(Assignee)

Comment 13

16 years ago
Fix checked into the trunk.
Status: NEW → ASSIGNED

Comment 14

16 years ago
Reassign QA Contact to ji@netscape.com
QA Contact: yulian → ji

Comment 15

16 years ago
After this has been tested on the trunk, please update the bug.
Keywords: adt1.0.0
(Reporter)

Comment 16

16 years ago
Verified on 04/16 and 04/17 trunk builds. Both search and migration problems
using double-byte base DN are fixed on the trunk.

Comment 17

16 years ago
adt1.0.0+ (on ADTs behalf) approval for checkin to 1.0 branch. Pls check this
into the 1.0 branch and trunk today. After, this has landed on the branch, pls
add the fixed1.0.0 keyword.
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Comment 18

16 years ago
Fix was checked into the trunk on 4/15
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 19

16 years ago
Comment on attachment 78597 [details] [diff] [review]
patch v2 (includes fix for migration)

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #78597 - Flags: approval+
(Assignee)

Comment 20

16 years ago
Fix checked into the branch.
Keywords: fixed1.0.0
(Reporter)

Comment 21

16 years ago
Verified with 04/19 branch builds.
Status: RESOLVED → VERIFIED
Keywords: verified1.0.0

Comment 22

16 years ago
*** Bug 138618 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 23

16 years ago
Removed fixed1.0.0 keyword since I already verified on the branch and added
verified1.0.0 keyword.
Keywords: fixed1.0.0
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.