The default bug view has changed. See this FAQ.

TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_empty_reply_below

RESOLVED FIXED in Thunderbird 51.0

Status

Thunderbird
General
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: Jorg K (GMT+1), Assigned: Jorg K (GMT+1))

Tracking

unspecified
Thunderbird 51.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 months ago
First seen here:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=93fae187ff9b3dbc56e53c89388b6e2f36fde00b

Most likely due to the landing of bug 1265800.

https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32-debug/1471882634/comm-central_xp_ix-debug_test-mozmill-bm112-tests1-windows-build4.txt.gz

says:

SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_empty_reply_below
10:01:38     INFO -    EXCEPTION: The linebreak should be preceded by a span.: 'br' != 'span'.
10:01:38     INFO -      at: test-folder-display-helpers.js line 2858
10:01:38     INFO -         assert_true test-folder-display-helpers.js:2858 11
10:01:38     INFO -         assert_equals test-folder-display-helpers.js:2845 3
10:01:38     INFO -         subtest_adding_filelinks_to_plaintext_reply_below test-cloudfile-attachment-urls.js:600 3
10:01:38     INFO -         try_with_and_without_signature_in_reply_or_fwd test-cloudfile-attachment-urls.js:203 3
10:01:38     INFO -         test_adding_filelinks_to_empty_reply_below test-cloudfile-attachment-urls.js:510 3
10:01:38     INFO -         Runner.prototype.wrapper frame.js:585 9
10:01:38     INFO -         Runner.prototype._runTestModule frame.js:655 9
10:01:38     INFO -         Runner.prototype.runTestModule frame.js:701 3
10:01:38     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
10:01:38     INFO -         runTestDirectory frame.js:707 3
10:01:38     INFO -         Bridge.prototype._execFunction server.js:179 10
10:01:38     INFO -         Bridge.prototype.execFunction server.js:183 16
10:01:38     INFO -         Session.prototype.receive server.js:283 3
10:01:38     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
10:01:38     INFO -  SUMMARY-PASS | test-cloudfile-attachment-urls.js::setupTest
10:01:38     INFO -  SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_nonempty_reply_below
10:01:38     INFO -    EXCEPTION: The linebreak should be preceded by a blockquote.: 'span' != 'blockquote'.
10:01:38     INFO -      at: test-folder-display-helpers.js line 2858
10:01:38     INFO -         assert_true test-folder-display-helpers.js:2858 11
10:01:38     INFO -         assert_equals test-folder-display-helpers.js:2845 3
10:01:38     INFO -         subtest_adding_filelinks_to_reply_below test-cloudfile-attachment-urls.js:563 3
10:01:38     INFO -         try_with_and_without_signature_in_reply_or_fwd test-cloudfile-attachment-urls.js:199 3
10:01:38     INFO -         test_adding_filelinks_to_nonempty_reply_below test-cloudfile-attachment-urls.js:525 3
10:01:38     INFO -         Runner.prototype.wrapper frame.js:585 9
10:01:38     INFO -         Runner.prototype._runTestModule frame.js:655 9
10:01:38     INFO -         Runner.prototype.runTestModule frame.js:701 3
10:01:38     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
10:01:38     INFO -         runTestDirectory frame.js:707 3
10:01:38     INFO -         Bridge.prototype._execFunction server.js:179 10
10:01:38     INFO -         Bridge.prototype.execFunction server.js:183 16
10:01:38     INFO -         Session.prototype.receive server.js:283 3

test-cloudfile-attachment-urls.js is a horrible test digging around the DOM and making all sorts of assumptions.
(Assignee)

Updated

7 months ago
Summary: TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_empty_reply_below TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cl → TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_empty_reply_below
(Assignee)

Comment 1

7 months ago
Oops, I forgot to mention the full failure:

TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_empty_reply_below
TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\cloudfile\test-cloudfile-attachment-urls.js | test-cloudfile-attachment-urls.js::test_adding_filelinks_to_nonempty_reply_below
(Assignee)

Comment 2

7 months ago
Reproducible locally, two errors per comment #0, I'll look into it.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 months ago
Created attachment 8784268 [details] [diff] [review]
Proposed fix (v1).

Due to changes in break handling/positioning/etc. in bug 1265800 we now need to be more flexible when analysing the DOM to find what we expect.

This test is a real pain, since it expects one exact DOM and nothing else. With the additional lines proposed here, it passes.
Attachment #8784268 - Flags: review?(mkmelin+mozilla)

Comment 4

7 months ago
Comment on attachment 8784268 [details] [diff] [review]
Proposed fix (v1).

Review of attachment 8784268 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin

::: mail/test/mozmill/cloudfile/test-cloudfile-attachment-urls.js
@@ +594,5 @@
>      br = assert_previous_nodes("br", root, 1);
>      // If no text was entered, just grab the last br's previous sibling - that
>      // will be the span.
>      span = br.previousSibling;
> +    // Sometimes we need to skip one more linebreak.

Sometimes, or always?
Attachment #8784268 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 5

7 months ago
Sometimes. I tested that.
(Assignee)

Comment 6

7 months ago
https://hg.mozilla.org/comm-central/rev/7e9219cf88c4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 51.0
You need to log in before you can comment on or make changes to this bug.