Enable eslint for browser/components/shell

RESOLVED FIXED in Firefox 51

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

Trunk
Firefox 51
Points:
---

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(1 attachment)

Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8783767 [details]
Bug 1297239 - Enable eslint for browser/components/shell.

https://reviewboard.mozilla.org/r/73454/#review71358

Thanks for doing this!

::: browser/components/shell/content/setDesktopBackground.js:2
(Diff revision 1)
> -# License, v. 2.0. If a copy of the MPL was not distributed with this
> -# file, You can obtain one at http://mozilla.org/MPL/2.0/.
> +* License, v. 2.0. If a copy of the MPL was not distributed with this file,
> +* You can obtain one at http://mozilla.org/MPL/2.0/. */

Nit: line up the `*` please.

::: browser/components/shell/content/setDesktopBackground.js:140
(Diff revision 1)
> -        var y = (this._screenHeight - height) / 2;
> +        let y = (this._screenHeight - height) / 2;
>          ctx.drawImage(this._image, x, y, width, height);
>          break;
> -      case "FIT":
> +      }
> +      case "FIT": {
>          //Try maxing width first, top and bottom borders

Nit: update this comment with a space before and . after while we're here?
Attachment #8783767 - Flags: review?(gijskruitbosch+bugs) → review+
Comment hidden (mozreview-request)

Comment 4

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aac36e73b97a
Enable eslint for browser/components/shell. r=Gijs

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/aac36e73b97a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Duplicate of this bug: 1197745
You need to log in before you can comment on or make changes to this bug.