Yahoo Popups do not display content.

VERIFIED DUPLICATE of bug 98654

Status

VERIFIED DUPLICATE of bug 98654
17 years ago
14 years ago

People

(Reporter: mgalli, Assigned: trudelle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Tested with Mozilla: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9)
Gecko/20020308

You can test this using Yahoo web site or use my simples testcase based in the
notes I received from Yahoo folks. Here is the tetscase scenarios: 

1) testing via Yahoo web site:
------------------------------
    Clear the cookies and type some query to search: sidebar tabs (for example)
    if the new popup appears, note the content is blank (this is the problem). 
    An FYI is that we are already working with Yahoo on this so I guess the 
    evangelism issue is fine. 

2) Testing via testcase
-----------------------
    Click the testcase attached. 

Here is what happens
--------------------

    The page.html have a JavaScript code that launches a new window using
(Reporter)

Comment 1

17 years ago
opps (I hit tab and space by mistake)..

Here is what happens:
---------------------
The page.html have a JavaScript code that launches a new window using
window.open. This new window is a blank: window. After, JS code will script
(document.write) the new window. The content that is included in the new page
looks like:

<html><body><script> window.location="http://somesite";</script></body></html>

More comments on the results:
-----------------------------
The window.location does not work. The page keeps blank. 

Workaround:
----------
When I script a function in the code, and add the onload event handler, then it
works. I will file the testcases (problem and workaround).
Summary: Yahoo Popups do not display content. → Yahoo Popups do not display content.
(Reporter)

Comment 2

17 years ago
Created attachment 73263 [details]
simple testcase demonstrating the problem. 

This version, main HTML page creates window.open and document.write JS code
setting window.location content.
(Reporter)

Comment 3

17 years ago
Created attachment 73264 [details]
Simple testcase with workaround

This testcase I included the window.location inside one function and called
this function in the onload event.

*** This bug has been marked as a duplicate of 98654 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.