Pinned tab with Slack partially disappears

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: tor.klingberg, Unassigned)

Tracking

48 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8783911 [details]
slack_tab.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728204513

Steps to reproduce:

I have three pinned tabs: Gmail, Slack (slack.com) and an other Gmail.


Actual results:

After a while the Slack tab breaks. There is no favicon shown and clicking it does nothing. I can still switch to the Slack tab with next tab/previous tab keyboard shortcuts, and everything inside it seems to work fine. It is not highlighted the way one of the Gmail tabs are when active.

Restarting Firefox does not always fix the issue, but if I restart several times it eventually goes back to normal for a while.
(Reporter)

Comment 1

2 years ago
I use Ubuntu 14.04.5 with the default Unity desktop.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Firefox: 51.0a1, Build ID  20160825030226
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

I have tested this issue on the latest Firefox (48.0.2) release and latest Nightly (51.0a1) but I could not reproduce it. I have used the entire day Firefox release with the pinned tab Slack homepage, but the favicon did not disappeared at all.

Can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(tor.klingberg)
(Reporter)

Comment 3

2 years ago
I will try that during next week. It might only happen when you are logged in to a Slack team. I suspect that it's triggered by Slack changing the favicon to alert for unread messages, or something similar.
Firefox: 48.0.2, Build ID: 20160823121617
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0

Have you managed to retest this with a new clean profile or in safe mode as I suggested in comment 2? Is this still reproducible?
 
Also, I have retested this with a slack.com account but I could not reproduce it. When I have unread messages, on the top right corner on the favicon, a red semicircle is displayed. I have tested with different scenarios for unread messages. For example I have restart the browser (with session restore enabled), reloaded all tabs, minimized and maximized the browser, leaved the computer in sleep mode, but the favicon for the pinned tab was correctly displayed every time.
(Reporter)

Comment 5

2 years ago
I didn't use a clean profile, but the bug has stopped happening. I guess that's the magic of reporting a bug.
Hi Klingberg,

Thanks for your reply. Considering this I will close this bug as resolved - wfm. If this issue is still reproducible on a new clean profile, fell free to reopen this bug and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(tor.klingberg)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.