update Travis CI infrastructure to use python 2.7.11+

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Currently, Travis CI tests Socorro using Python 2.7.9. We're in the process of upgrading the -stage and -prod environments to 2.7.11. There are some non-backwards-compatible differences between the two. Additionally there are a bunch of libraries out there that had to do an update to support Python 2.7.11. It behooves us to have Travis CI running Socorro tests with Python 2.7.11 at least.

This bug covers fixing our infrastructure such that Travis CI runs Socorro tests with Python 2.7.11+.
I think this is pretty important because of the differences between Python versions. It'd be a good change to make. If it turns out that it's super hard (e.g. Travis can't run with Python 2.7.11), we should figure out another course of action.
Priority: -- → P1
I skimmed the docs and I think the issue is that Travis is using Python 2.7.9 because it's using Ubuntu 12.04. I don't see anything in the Socorro scripts/build.sh and friends nor in the Travis configuration that's pinning the version of Python.

Travis lets you specify the Python version, so I'm going to try to specify 2.7.11 and 2.7.12 and see what happens.

Anyhow, grabbing this.
Assignee: nobody → willkg
Status: NEW → ASSIGNED
Got it working.

One thing I noticed is that Travis is testing with postgres 9.3, but we're using postgres 9.4. We should up that. It might reduce the time it takes to run the tests because Travis currently uninstalls postgres 9.4 to put 9.3 on.
This only affects Travis, so I'm going to close it out as FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.