Add-ons are disabled thought xpinstall.signatures.required has been set to false in Firefox version 48.0.1 and previous (Dutch) versions.

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Charleshan Denninger, Unassigned)

Tracking

({addon-compat, autotest-issue})

48 Branch
addon-compat, autotest-issue
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

I did set xpinstall.signatures.required to 'false' a while ago.
See: https://support.mozilla.org/nl/kb/add-on-ondertekening-in-firefox?as=u&utm_source=inproduct for instructions.

Besides that I did configure Firefox update to warn me of incompatible add-ons before installing an update.


Actual results:

Today Firefox crashed and was updated to version 48.0.1 during the reboot of it. It crashed twice by the way.
Now it tells me my add-ons are disabled although xpinstall.signatures.required is still 'false'!


Expected results:

1) The value xpinstall.signatures.required false should not be neglected.
2) The same goes for warning me on incompatible add-ons by automatic Firefox updates.
Both settings where set but neglected! Please resolve these two bugs!
(Reporter)

Updated

a year ago
Keywords: addon-compat, autotest-issue
Starting with Firefox 48, that pref has no longer any effect. See https://blog.mozilla.org/addons/2016/07/29/extension-signing-availability-of-unbranded-builds/ for more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 2

a year ago
Well, Firefox did not tell me of the incompatible add-ons during her updating now did it?
So according to me it is still a bug!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

a year ago
In addition:
1) I only have the Dutch Firefox version, but the option "Mij waarschuwen als dit een van mijn add-ons zal uitschakelen" free translated in English: "Warn me if ~ updating ~ will disable one of my add-ons" is still on.
2) The Upgrade has been form version 48.0 (August 6) to 48.0.1 (August 23), in the previous (48.0) version my add-ons still worked.
3) A simple rollback does not seems to be possible as far as I could find (3443 hits on 'rolback firefox update' in support https://support.mozilla.org/nl/products/firefox/install-and-update-firefox).
Is removing and reinstalling the older Firefox (and my favourites, add-ons, settings etcetera) really the only option?

I've already lost hours by this bug, thanks!
Please don't reopen this bug.

The option you mention is about technical incompatibilities only, not about signing. The blog post I linked offers unbranded builds in which the preference will still work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.