Crash when email doesen't have a DATE:

VERIFIED FIXED

Status

MailNews Core
Backend
--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Ben Johnson, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Description:
   Supposidly, raw email is sposed to have a DATE: feild in the header. For 
some dumb reason, mail arrives without it. Mozilla seems to crash, at least in 
Windows 98/ME. Possibly (untested by me, but postulated by Netscape's 
behaviour) it might interpret the non existing date as being 0 seconds from the 
Unix Epoc (Jan 1,1970). 

To reproduce this bug:
  To simupte a non-dated email send youself some email and move it to a 'local 
folder'. Find where your version of Mozilla stashed your email and edit the 
file - find the email and delete the DATE: line in the header. Save and reopen 
Mozilla mail, and view the email. Odd things will happen on Win98.

Suguested remedy:
  Easy: when an incomming email arrives without a date, add one with the 
current time, or have Mozilla dispay the timestamp that mozilla itself adds.
  Hard: Use other clues in the email to derive a good guess of the date. This 
is really hard because as far as I know, only the DATE: feild is a standard.

FYI:
  Netscape 6.2.1 interperates a non existing date as being 0 seconds from the 
Unix Epoc (Jan 1,1970 GMT) and will display a date simelar to - 9:00 PM 
December 31, 1969. if you live anywhere else besides the prime meridian.
  Outlook Express finds other date clues (server stamping in the header) in the 
email and presents them to the user. Unconfirmed but roumoured, afterwards, 
Outlook Express erases several random files and then goes though 
the 'favorites' folder and tries to log in to any website with the word 'Bank' 
in the description. Them, by using a clever expression parser and random click 
events, it then tries to transfer all funds to Bill Gates account in the 
Behamas. It's just a roumour though, but my bank account has been suspicisouly 
low after testing it.

Note:
 I hope I'm not being a **** for catagorizing the severity as major, but it 
really bugs (pun intended) a few people that I know. Thanks for all your work, 
I appreciate it! -Ben
(Reporter)

Comment 1

17 years ago
OK - I'm an idiot, I tested the latest build as of March 08 2002: Mozilla/5.0 
(Windows; U; Win 9x 4.90; en-US; rv:0.9.9+) Gecko/20020308, and Mozilla behaves 
perfectly. I hope I diden't waste too much of your time.

I assigned the bug as FIXED - but that's just my guess.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
verified (per reporter), though we prefer to use 'worksforme' unless you can
point to a patch.  thanks for reporting back, nonetheless.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.