Text copy-paste loses CR LF and whitespace (XMP tag)

VERIFIED DUPLICATE of bug 69792

Status

()

VERIFIED DUPLICATE of bug 69792
17 years ago
17 years ago

People

(Reporter: id11, Assigned: harishd)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

See steps to reproduce. If the URL is not accessible create this HTML file:
===========================================================================
<xmp>
    =Side Effects:None
    =This code is copyrighted and has limited warranties.
    =Please see
http://www.1PerlStreet.com/xq/ASP/txtCodeId.225/lngWId.6/qx/vb/scripts/ShowCode.htm
    =for details.
    =**************************************
    
    #!/usr/local/bin/perl
    $, = ' '; $\ = "\n";

		</xmp>
===========================================================================

Reproducible: Always
Steps to Reproduce:
1. Open the URL or the HTML file created from the text between the ==== lines,
using Mozilla.
2. Select the text with the mouse (i.e. left button down, drag from top to
bottom, then ctrl-C)
3. Paste the selection in Notepad
*** It becomes a SINGLE LONG line - all line breaks are lost and some whitespace
is lost too.

Comment 1

17 years ago
--> qa tpreston@netscape.com
QA Contact: paw → tpreston

Comment 2

17 years ago
Isn't XMP a deprecated Microsoft extension?  Not sure who should get this, but
it seems like a minor edge case we don't need to fix for MachV. ->future
Target Milestone: --- → Future

Comment 3

17 years ago
-->DOM to Text Conversion
Assignee: trudelle → harishd
Component: XP Apps → DOM to Text Conversion
QA Contact: tpreston → sujay
Summary: Text copy-pase looses CR LF and whitespace → Text copy-paste loses CR LF and whitespace (XMP tag)

Comment 4

17 years ago
This is a duplicate of Bug 69792

*** This bug has been marked as a duplicate of 69792 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.