Mac: Mail database becomes corrupted in short time

VERIFIED DUPLICATE of bug 122361

Status

MailNews Core
Backend
--
major
VERIFIED DUPLICATE of bug 122361
16 years ago
10 years ago

People

(Reporter: Joel Nelson (don't send email), Assigned: Navin Gupta)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I just installed Mozilla less than a week ago.  I installed the Milestone
release of 0.9.8.  Within a few hours one profile had an error -- a subfolder
would show one unread message in the folder and not show the message. I deleted
the profile and started over.   Within a couple of days one of my two user
profiles was corrupted so that the program would crash when opening a new
message.   Then soon after the other profile (the one that replaced the
initially corrupted profile) became corrupted, with the same problem.  I
upgraded to 0.9.9+ (2002030808) and the problem was still not fixed.
    I have used Outlook Express for a couple years and never had corruption
problems.   On earlier Mozilla builds (before I had to initialize my hard disk
last year) I also encountered this problem.   This is a definite bug in Mozilla,
and in my opinion, it needs to be resolved by 1.0 since a lot of people will not
want to use Mozilla as their default emailer if they have to create a new
profile every few days!

Comment 1

16 years ago
are you using imap or pop3? do you have mail filters? What kind of operations do
you do before the db's get out of sync? We get reports of these problems, but
they either go away, or they simply can't be reproduced.
Component: Mail Database → Mail Back End
(Reporter)

Comment 2

16 years ago
Using POP3 (multiple accounts)
No filters

Operations:
Standard send/receive mail operations
Create subfolders to store messages

The only way I see to get rid of this issue is to delete the profile.  It's hard
to reproduce since I don't know how or why the profiles get corrupted...
although for me that problem has been ongoing since I started working with
Mozilla back at the release of the Netscape 6 preview 1.
(Reporter)

Comment 3

16 years ago
Using POP3 (multiple accounts)
No filters

Operations:
Standard send/receive mail operations
Create subfolders to store messages

The only way I see to get rid of this issue is to delete the profile.  It's hard
to reproduce since I don't know how or why the profiles get corrupted...
although for me that problem has been ongoing since I started working with
Mozilla back at the release of the Netscape 6 preview 1.

Comment 4

16 years ago
have you tried simply removing the .msf file for the folder in question? E.g,
Inbox.msf for the Inbox, and reselecting the folder? Or is the corruption more
pervasive somehow?

Do you often read messages while you're getting new mail, or move messages while
retrieving new mail?

Do you often delete/rename sub-folders? There was a bug on the mac involving
deleting sub-folders.
(Reporter)

Comment 5

16 years ago
I do not rename or delete subfolders much, although I did experience the
deleting issue on Mac.  It seems to be fixed in the nightly build I downloaded
today.
   I haven't tried deleting the .msf file.   I do often read messages while
receiving mail.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → olgam
Summary: Mail database becomes corrupted in short time → Mac: Mail database becomes corrupted in short time

Comment 6

16 years ago
Navin is working on several dups of this.
Assignee: bienvenu → naving
(Assignee)

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 122361 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.