css calc() table cells' width is ignored

RESOLVED DUPLICATE of bug 957915

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 957915
3 years ago
7 months ago

People

(Reporter: numminorihsf, Unassigned)

Tracking

(Blocks 1 bug, {parity-chrome, testcase})

48 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fix-optional, firefox58 affected)

Details

(Whiteboard: [webcompat])

Attachments

(1 attachment)

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728203720

Steps to reproduce:

1. Create an table.
2. Create 3 (for example) table cells with borders.
3. Remove left border from first cell and right border form last cell.
4. Set table cells width to `calc(33.333%)`
Example is here: https://jsfiddle.net/6fr44a9k/4/


Actual results:

Cell have not width = 33.333%.
First and last cells have width less than 2nd.



Expected results:

All cells should have width = 33.333%.
Reporter

Updated

3 years ago
Summary: css calc() with 1 value is ignored → css calc() table cells' with is ignored
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID:  20160824030337

I was able to reproduce the problem in both 48.0 and the nightly build 51.0a1.  The tables work fine in the example Konstantin provides as long as the CSS reads "width: 33.333%;".  

Change it to "width: calc(33.333%);" and the cells render in an odd way.  First and last cell are about 25% wide, middle cell about 50%.

Restore the boundaries on the left and right side and both cases work.

(Chromium renders both cases the same, evenly divided cells, one-third of the width.)
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Tables
Ever confirmed: true
Product: Firefox → Core

Comment 2

2 years ago
I ran in to this issue today when I needed to use inline styles in table cell widths, but wanted to show the math used, instead of random, "magic" numbers. This bug prevents me from doing so. IE and Edge are also affected.

Here's my test case: http://codepen.io/stowball/pen/ZLZBrM
Blocks: 1376206
Priority: -- → P2
Whiteboard: [parity-chrome][webcompat]
Summary: css calc() table cells' with is ignored → css calc() table cells' width is ignored

Comment 3

2 years ago
Posted file simple testcase
simple testcase added

Updated

2 years ago
Keywords: testcase
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-chrome
Whiteboard: [parity-chrome][webcompat] → [webcompat]

Comment 5

7 months ago
Resolving as DUPLICATE of bug 957915
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 957915
You need to log in before you can comment on or make changes to this bug.