Closed Bug 1297944 Opened 8 years ago Closed 3 years ago

LayerManagerComposite::SetShadowOpacity should involve a flag which indicates whether the opacity is specified by animation or not

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: hiro, Assigned: hiro)

Details

Attachments

(1 file)

In bug 1279071, SetShadowOpacitySetByAnimation() which has an argument of the flag has been introduced, but we could unify SetShadowOpacity() and SetShadowOpacitySetByAnimation().

Assigning to me temporary just in case that this bug does not bother gfx team triage.
Attachment #8785547 - Attachment description: 1297944.patch → 1297944.patch Unified SetShadowOpacitySetByAnimation(bool) into SetShadowOpacity(float, bool).
Attachment #8785547 - Flags: review?(bbirtles)
Attachment #8785547 - Flags: review?(bbirtles) → review?(hiikezoe)
Comment on attachment 8785547 [details] [diff] [review]
1297944.patch
Unified SetShadowOpacitySetByAnimation(bool) into SetShadowOpacity(float, bool).

This code is good but I prefer to use enum value instead of boolean.

Could you please add an enum class and use it something like this;

enum class ByWhich {
  Animation,
  NonAnimation
}

I don't think it's a great name but I have no idea for now.
Attachment #8785547 - Flags: review?(hiikezoe)
It seems that SetShadowTransformSetByAnimation(bool) exists besides SetShadowOpacitySetByAnimation(bool).
Should the name of the enum class adjust these?
(In reply to Hiroyuki Ikezoe (:hiro) from comment #2)
> Comment on attachment 8785547 [details] [diff] [review]
> 1297944.patch
> Unified SetShadowOpacitySetByAnimation(bool) into SetShadowOpacity(float,
> bool).
> 
> This code is good but I prefer to use enum value instead of boolean.
> 
> Could you please add an enum class and use it something like this;
> 
> enum class ByWhich {
>   Animation,
>   NonAnimation
> }
> 
> I don't think it's a great name but I have no idea for now.

It seems that SetShadowTransformSetByAnimation(bool) exists besides SetShadowOpacitySetByAnimation(bool).
Should the name of the enum class adjust these?
Please leave the function for transform as it is in this bug.  There are many callers of SetShadowTransform().
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: