Closed Bug 1297977 Opened 3 years ago Closed 3 years ago

2.13 - 6.75% damp / tart / tps (osx-10-10, windows7-32, windows8-64) regression on push 649c62d13b57bf6966bc70f4da603d52c92070de (Wed Aug 24 2016)

Categories

(Firefox :: Untriaged, defect)

51 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: ashiue, Assigned: smaug)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push 649c62d13b57bf6966bc70f4da603d52c92070de. As author of one of the patches included in that push, we need your help to address this regression.

Summary of tests that regressed:

  damp summary osx-10-10 opt: 300.69 -> 320.35 (6.54% worse)
  tart summary windows7-32 opt: 6.21 -> 6.36 (2.43% worse)
  damp summary windows7-32 opt: 318.13 -> 334.57 (5.17% worse)
  tart summary windows8-64 opt: 5.68 -> 5.87 (3.47% worse)
  damp summary windows8-64 opt: 303.64 -> 324.12 (6.75% worse)
  damp summary windows7-32 opt e10s: 266.89 -> 282.48 (5.84% worse)
  tps summary windows8-64 opt: 69.23 -> 70.7 (2.13% worse)


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=2704

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
After doing some retriggers, this issue might be caused by one of following patches:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f7de27ec1079a5b4029292e6589c72463db85b0d&tochange=649c62d13b57bf6966bc70f4da603d52c92070de

Hi Olli, as you are the patch author, can you take a look at this and determine what is the root cause? Thanks!
Flags: needinfo?(bugs)
Please back out bug 1297367.
Flags: needinfo?(bugs)
Bug 1297367 backed out.
Assignee: nobody → bugs
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
thanks Ryan!
You need to log in before you can comment on or make changes to this bug.