[XBLFC] min-width of buttons is about 9ex (<input type="button"> or <button/>)

RESOLVED FIXED in mozilla1.2alpha

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: jrgmorrison, Assigned: hyatt)

Tracking

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need info])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
the min-width of '<input type="submit" value="X">' appears to be 
about 9 characters wide (i.e., doesn't size to content below 9 
chars).

[Comments based on testing with 2002030710 trunk build, classic skin, win2k,
XBL Form Controls enabled, unless otherwise noted. madhur: could you test this
on the full matrix (Classic|Modern) X (win32|MacOS9|MacOSX|Linux) and update
this bug with the status on those platform/skin combinations.  Thanks.]
(Reporter)

Comment 1

17 years ago
Created attachment 73371 [details]
testcase for min-width of <input type="button"> or <button/>
(Reporter)

Comment 2

17 years ago
adding nsbeta1. I think we do need to consider each of these for machv if we 
are to do xbl-based form controls.
Keywords: nsbeta1
As a note, it makes sense to never go below about 2 chars in width (that way
there is some padding on buttons if the label is a single character).
OS: Windows 2000 → All
Hardware: PC → All
need to remove min-width in classic button.css
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 5

17 years ago
The patch in 129786 also fixes this.

--> me
Assignee: bryner → hyatt
Status: ASSIGNED → NEW
(Assignee)

Comment 6

17 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Reopening. You didn't fix modern, so buttons in modern still look like crap.

Buttons in classic are much better now, modulo bug 130303
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

17 years ago
Nav triage team needs info: Are we going to use modern for XBL form controls? 
If not, this should not be needed for MachV.
Whiteboard: [need info]
*** Bug 131840 has been marked as a duplicate of this bug. ***
Re-resolving, since we are not using modern for XBL form controls.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
nsbeta1- per Nav triage team, ->1.2 (in case of reopen)
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2alpha

Updated

17 years ago
QA Contact: madhur → tpreston
You need to log in before you can comment on or make changes to this bug.