Cannot focus / type anything into TEXTAREA

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Arthit Suriyawongkul, Assigned: rods (gone))

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020301
BuildID:    2002030103

at page  http://linux.thai.net/wwwboard/msg00429.php
at the bottom,  there're 3 TEXT INPUT and 1 TEXTAREA.

we cannot put the focus on the TEXTAREA,
as the result we cannot type anything into that TEXTAREA.

this problem does not occurs with other sites.

Reproducible: Always
Steps to Reproduce:
1. go to http://linux.thai.net/wwwboard/msg00429.php  (or any page of this webboard)
2. click on the TEXTAREA
3. try typing something
... not work :(

Actual Results:  none of text has been putted into TEXTAREA

Expected Results:  seeing what i've typing in the TEXTAREA

in the same website

the TEXTAREA at this url do working fine
  http://linux.thai.net/wwwboard/index.html

but the rest, not work with Mozilla, work fine with Internet Explorer.
for example:
   http://linux.thai.net/wwwboard/msg00429.php

occurs in every version of Windows (as tested -- 98 SE, ME, 2000, XP)
Worksforme, linux build 2002-03-08-07.  I have no problems typing in that
textarea.  Is this windows-only?

Comment 2

16 years ago
confirming using build 2002030803 on Win2k but I have a hard time producing a
reproducible testcase.

Comment 3

16 years ago
Created attachment 73396 [details]
Reduced testcase which trigger bug on Windows (2002030803) but not on Linux.

Here's a reproducible testcase that prevent Mozilla on Windows to enter any
character in the textarea. It's due to a 'unknown' character already 'present'
within the textarea. If you delete this character, it's possible to type
something in the textarea.
On Linux, you'll notice when clicking in the form, there's an initial 'blank'
space.

Updated

16 years ago
Keywords: testcase

Updated

16 years ago
QA Contact: madhur → tpreston

Comment 4

16 years ago
** build 20020422 and Windows XP
the textarea works for me -I do not see a loss of focus or the fact that you
cannot type in the text area.
The carat starts at a varied distance from the start of the textarea box. There
is an area you cannot type in at begining of the text area box about 2-12
characters it seems to vary in size. After you back space or delete that area it
works fine to type where the blank area is though.   
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
OK, seems it has been fixed now (Build ID 2002041711 - Windows 98 SE).
Thanks :)

i think we can close this bug.
Status: RESOLVED → CLOSED
Sorry for the spam... this should be RESOLVED, not CLOSED.
Status: CLOSED → UNCONFIRMED
Resolution: WORKSFORME → ---
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
When this bug is verified, please mark it verified, not closed.
You need to log in before you can comment on or make changes to this bug.