[Windows] Shell Icon for .ico files should be the file itself, not the default Mozilla icon

VERIFIED DUPLICATE of bug 216187

Status

Core Graveyard
File Handling
--
minor
VERIFIED DUPLICATE of bug 216187
16 years ago
2 years ago

People

(Reporter: Russell Odom, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

In Windows, the installer (I presume it's the installer) associates .ico files
with Mozilla. It sets the icon for these files to the standard Mozilla icon.

However, icon files contain their own icon - this is very useful and I would
expect to see it! (This is why I'm setting the severity to Minor rather than
Enhancement.) The installer should therefore set the icon for these files to be
the file itself - that is, the registry key
'HKEY_CLASSES_ROOT\MozillaICO\DefaultIcon\(Default)' (type REG_SZ) should have
the value '%1' (or possibly '"%1"' - the double quotes *may* be required for
icons with spaces in the filename, but I haven't tested this).

I imagine this is a simple change to the installer - I'll attach a registry
patch which will do the job.

Reproducible: Always
Steps to Reproduce:
1. Install Mozilla, make sure it associates itself with icon files
2. View a directory containing a .ico file in Windows Explorer

Actual Results:  File has standard Mozilla icon

Expected Results:  File should have its contents as the icon
(Reporter)

Comment 1

16 years ago
Created attachment 73385 [details]
Registry patch to make the icon for .ico files to be the file itself

This will set the icon for .ico files to be the file itself. I've tested it on
Win2000 and it works (so it should work in WinXP too, however the first line
*may* need changing to "REGEDIT4" to get it to work on Win9x).

Save it with the extension .reg, and double-click to apply.

Of course, use at your own risk :-)

Comment 2

16 years ago
It's not the installer that does this. It's done in the Prefs -> Advanced ->
System pref dialog
Assignee: dveditz → law
Component: Installer → File Handling
QA Contact: bugzilla → sairuh

Comment 3

16 years ago
*** Bug 132857 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

16 years ago
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → petersen
Bug 216187 will provide the fix for this.
Depends on: 216187
Comment on attachment 73385 [details]
Registry patch to make the icon for .ico files to be the file itself

This isn't a binary file :-)
Attachment #73385 - Attachment mime type: application/octet-stream → text/plain

*** This bug has been marked as a duplicate of 216187 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
Why is an Older bug being marked as a Duplicate of a Newer bug?

shouldn't bug #216187 be marked as a duplicate of this bug #129825 ??? 
Verified

The reason is because the patch exists in the other bug. An older bug can be
marked dupe of a newer one if the newer one has more useful information. Its
nothing against the reporter of this bug, it just happened the patch was in the
other bug and was already approved.

If anyone has more questions about why, please email me and Biesi with the question.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.