Closed Bug 1298313 Opened 3 years ago Closed 3 years ago

[e10s disabled] Long-touch context menu is broken on Windows

Categories

(Core :: Panning and Zooming, defect, P1)

50 Branch
Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox49 --- unaffected
firefox50 + verified
firefox51 --- verified

People

(Reporter: torvin, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot.png
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160824004001

Steps to reproduce:

Long-touch any item in Firefox to open context menu (I have a laptop with a touchscreen)


Actual results:

* The menu that appears have wrong set of items (e.g. no 'View Image' for images). The items that appear seem random and usually affected by the last item I right-click (with mouse)
* None of the menu items work - touching or clicking them (with a mouse) simply doesn't do anything.
* On the first touch after Firefox starts the menu simply contain every single possible menu item: (see screenshot) - I simply long-touched the Firefox logo on that page


Expected results:

Context menu should work as expected. The same way it works when I'm using right-click to open it.
Tested in both Win 8.1 & Win 10 with the same result.
Torvin: Is this only broken on Firefox 50? If you could please try the current release or beta 49 it would be appreciated. Thanks.
Flags: needinfo?(torvin)
Works fine in current beta (49.0b7)
Flags: needinfo?(torvin)
ni on Andrei for further investigation. Not sure if you have a machine with a touchscreen you can test with.
Flags: needinfo?(andrei.vaida)
I could reproduce this on a Microsoft Surface Pro 2 device with Windows 10 64-bit.

On clean profiles this doesn't reproduce as the browser starts with e10s enabled. After restarting, e10s is automatically disabled and the issue occurs.
On touch devices, also the contextual menu options are not working (Open in New Tab / New Window / ...) with e10s disabled.

This is a Firefox 50 regression, introduced by bug 1256339:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a706323c0073b7cd72dc0c41a6601a91f15dea9b&tochange=6172a55a6ae8611317b89f18ca47f785df4ab877
Blocks: 1256339
Status: UNCONFIRMED → NEW
Component: Untriaged → Panning and Zooming
Ever confirmed: true
Flags: needinfo?(andrei.vaida)
Keywords: regression
Product: Firefox → Core
Assignee: nobody → bugmail
OS: Unspecified → Windows
Summary: Long-touch context menu is broken on Windows → [e10s disabled] Long-touch context menu is broken on Windows
[Tracking Requested - why for this release]: Regression in Firefox 50 that affects devices with touch screens.
I think I'll just back out bug 1256339. I was mostly doing that in bug 1292572 anyway, to fix a different issue.
I guess technically I'm only going to back out one of the three patches, so I'll do in this bug after testing it locally.
This is the backout patch. I tested it locally to make sure it fixes the problem.
Attachment #8786044 - Flags: review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/39710218be43
Revert the third patch from bug 1256339 because it broke long-press context menus in non-e10s mode. r=backout
https://hg.mozilla.org/mozilla-central/rev/39710218be43
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Comment on attachment 8786044 [details] [diff] [review]
Fix by backout of part 3 in bug 1256339

Approval Request Comment
[Feature/regressing bug #]: bug 1256339
[User impact if declined]: on desktop with e10s disabled, long-pressing to bring up the context menu is broken in various ways
[Describe test coverage new/current, TreeHerder]: There isn't any automated coverage of this touch long-press codepath, but I tested manually
[Risks and why]: low risk, this is straight-up backout of one of the patches in the regressing bug. I'll fix that one a different way which I was planning on doing anyway
[String/UUID change made/needed]: none
Attachment #8786044 - Flags: approval-mozilla-aurora?
Hi Torvin, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(torvin)
Comment on attachment 8786044 [details] [diff] [review]
Fix by backout of part 3 in bug 1256339

Backing out a patch that fixes a recent regression, Aurora50+
Attachment #8786044 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
It works now, thanks!
Flags: needinfo?(torvin)
Verified as fixed using latest Dev Edition 50.0a2 and latest Nightly 51.0a1 under Microsoft Surface Pro 2 with Win 10 64-bit.
Status: RESOLVED → VERIFIED
(In reply to Torvin from comment #16)
> It works now, thanks!

Fantastic! Thank you for the prompt reply. :)
You need to log in before you can comment on or make changes to this bug.