[http://www.medicover.pl] DHTML-based menu does not work

VERIFIED FIXED

Status

Tech Evangelism Graveyard
Polish
P3
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Gabriel Baines, Assigned: Jacek Piskozub)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The site uses DHTML-based menu. The JS code for the menu starts with the
following browser sniffing code:

 ns4 = (document.layers)? true:false	
 ie4 = (document.all) ? true:false

In case of mozilla both are false. 

Since the site does not provide any alternative way for accessing pages in menu,
the site is unusable in Mozilla.
(Assignee)

Comment 1

16 years ago
Confirming and accepting.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Summary: [http://www.medicover.pl] DHTML-based menu does not work → [http://www.medicover.pl] DHTML-based menu does not work
Target Milestone: --- → Apr
(Assignee)

Comment 2

16 years ago
I've prepared a version of the JavaScript file which makes it possible to use
the menu on the MediCover page with Mozilla/Netscape6. Not a finished work (the
scrollable menu on the right, invisibe with Mozulla, is not controlled by this
script) but it works with both Mozilla and IE. Attaching the file. I've sent the
file to the webmaster of MediCover site.
(Assignee)

Comment 3

16 years ago
Created attachment 74323 [details]
Javascript working with Netscape and IE
(Assignee)

Comment 4

16 years ago
No progress. Second evangelism letter sent.
Severity: minor → major
Priority: P2 → P3
Target Milestone: Apr → Aug
(Assignee)

Comment 5

16 years ago
No progress. Futuring the bug :-(
Target Milestone: Aug → Future

Comment 6

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009

Seems to work now...
(Assignee)

Comment 7

16 years ago
It really does! Thanks for the info. I checked the page a week ago. It seems it
was updated very recently.

Closing as FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
Hoho,.. ;) 

Looks like it's time to start little hall of fame at mozillapl'e e-Services page
- contrast will be better ;)

VERIFIED FIXED.
(Assignee)

Comment 10

16 years ago
Marking Verified per comment #8 

Marek: we have no power over mozillapl.org server content. Please contact
directly Piotr Bartecki 
Status: RESOLVED → VERIFIED

Comment 11

15 years ago
tech evang june 2003 reorg
Component: Europe: Central → Polish
Target Milestone: Future → ---
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.