If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Seamonkey does not shutdow completely due to a FUTEX timeout.

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Martin Mokrejs, Unassigned)

Tracking

SeaMonkey 2.42 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0 SeaMonkey/2.42a2
Build ID: 20160125013001

Steps to reproduce:

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0 SeaMonkey/2.42a2
Build identifier: 20160125013001

about:buildconfig
Source

Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/68328ff256b676964fd9d73ff1a96192262b915e
Build platform
target
x86_64-unknown-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
/usr/bin/ccache /builds/slave/c-aurora-lnx64-ntly/build/gcc/bin/gcc 	4.7.3 	-Wall -Wempty-body -Wpointer-to-int-cast -Wsign-compare -Wtype-limits -Wno-unused -Wcast-align -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe
/usr/bin/ccache /builds/slave/c-aurora-lnx64-ntly/build/gcc/bin/g++ 	4.7.3 	-Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -D_GLIBCXX_USE_CXX11_ABI=0 -pipe -DNDEBUG -DTRIMMED -g -freorder-blocks -Os -fno-omit-frame-pointer
Configure arguments

--enable-crashreporter --enable-release --enable-elf-hack --enable-stdcxx-compat --enable-default-toolkit=cairo-gtk3 --enable-application=suite --enable-optimize --enable-update-channel=aurora --enable-update-packaging --disable-debug --enable-tests --disable-elf-hack --enable-profiling --with-ccache=/usr/bin/ccache --with-external-source-dir=/builds/slave/c-aurora-lnx64-ntly/build


Actual results:

Seamonkey process doe snot exit completely upon Quit. Tracing the stale process shows the following:

$ strace -v -f -p 25269
Process 25269 attached with 16 threads
[pid 25282] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25298] futex(0x7f70a26eec1c, FUTEX_WAIT_PRIVATE, 1, NULL <unfinished ...>
[pid 25289] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 25287] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 25286] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 25285] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 25284] futex(0x7f70ac33920c, FUTEX_WAIT_PRIVATE, 1, NULL <unfinished ...>
[pid 25283] futex(0x7f70aedc940c, FUTEX_WAIT_PRIVATE, 255, NULL <unfinished ...>
[pid 25281] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25280] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25279] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25278] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25277] futex(0x7f70b24392cc, FUTEX_WAIT_PRIVATE, 5892, NULL <unfinished ...>
[pid 25274] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 25273] epoll_wait(7,  <unfinished ...>
[pid 25269] futex(0x7f70b243918c, FUTEX_WAIT_PRIVATE, 57, NULL <unfinished ...>
[pid 25285] <... restart_syscall resumed> ) = -1 ETIMEDOUT (Connection timed out)
[pid 25285] futex(0x7f70ac4f1cc0, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 25285] futex(0x7f70ac3392cc, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 109047, {1472226910, 609729000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
[pid 25285] futex(0x7f70ac4f1cc0, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 25285] futex(0x7f70ac3392cc, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 109049, {1472226910, 641904000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
[pid 25285] futex(0x7f70ac4f1cc0, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 25285] futex(0x7f70ac3392cc, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 109051, {1472226910, 674036000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
[pid 25285] futex(0x7f70ac4f1cc0, FUTEX_WAKE_PRIVATE, 1) = 0



Expected results:

I think the timeout should be interpreted, reported clearly to the user and seamonkey should quit anyway.

I use xfce4 desktop on Linux, is some of my daemons not responding. Which daemon is this connection about?
You are using a completely outdated prerelease version. Please try with a recent 2.45+ and reopen if you can reproduce the error with this one.

Linux has some hickups currently but there are 2.47a2 builds from mid August available:

https://archive.mozilla.org/pub/seamonkey/nightly/2016/

A tinderbox 2.46 is also available which should work for testing:

https://archive.mozilla.org/pub/seamonkey/tinderbox-builds/comm-beta-linux64/1472292884/
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Summary: Seamonkey does not shutdow completelydue to a FUTEX timeout. → Seamonkey does not shutdow completely due to a FUTEX timeout.
You need to log in before you can comment on or make changes to this bug.