Multiple clicking "Highlight All" dim become black

VERIFIED FIXED

Status

()

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: alice0775, Assigned: mikedeboer)

Tracking

(Blocks: 1 bug)

51 Branch
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/a65b35c8e5b17c2585968974aef1da67a8c56642
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 ID:20160826063819

Steps To reproduce:
1. Enable new findbar
  user_pref("findbar.highlightAll", true);
  user_pref("findbar.modalHighlight", true);
2. Open any web page
   (e.g. https://en.wikipedia.org/wiki/Firefox )
3. Open Find Bar (Ctrl+F)
4. Perform find with any term
5. Multiple click "Highlight All"

Actual Results:
dim become black

Expected Results:
toggle dim
(Reporter)

Comment 1

2 years ago
Created attachment 8785383 [details]
screenshot
(Assignee)

Updated

2 years ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 51.2 - Aug 29
Points: --- → 3
Flags: qe-verify+
Flags: firefox-backlog+
(Assignee)

Comment 2

2 years ago
After I try to reproduce this with my fix applied from bug 1298438, I can't reproduce this anymore.
Depends on: 1298438
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
The bug is fixed on Nightly 51.0a1 - verified on Window 7, Ubuntu 16.04 and Mac 10.11.
When multiple click on "Highlight All" another issue is observed: Emphasized highlight text disappears, but this is tracked on bug 1301684.
Status: RESOLVED → VERIFIED
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: affected → verified
You need to log in before you can comment on or make changes to this bug.