If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't check checkbox in javascript after moving it around

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
VERIFIED INVALID
16 years ago
9 years ago

People

(Reporter: Jan David Mol, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
when moving around a row in a table in javascript, and then do a
checkbox.checked = true for a checkbox on that row, mozilla fails to check
it. however, if I put an alert-call between moving and checking, the box does
get checked. IE5 checks the box in either case.

note: workaround: check the box with a settimeout('checkbox.checked=true',0)
call.
Jan, what build are you using?  I can't reproduce this problem with linux build
2002-03-08-07 -- the checkbox is checked in either case.
(Reporter)

Comment 2

16 years ago
i'm using windows '98, Mozilla 0.9.8 build 2002-02-04-06.
(Reporter)

Comment 3

16 years ago
Hmm I found and downloaded the latest nightly build (2002-03-10-08). Bug not
present there on win32 platform either. Sorry for my error :)

BTW: Behaviour in latest build is better than IE on this one. Check the box on
row 1 and it keeps checked even after moving it around. IE and latest Mozilla
milestone both forget the box was checked. (JavaScript only messes with box 2)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
marking verified, reported resolved as invalid.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.