Intermittent TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | expected OK

RESOLVED FIXED in Firefox 51

Status

()

defect
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aryx, Assigned: bevis)

Tracking

({intermittent-failure})

unspecified
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1294044 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=11320704&repo=fx-team

19:56:43     INFO - TEST-START | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm
19:56:53     INFO - PROCESS | 2656 | MARIONETTE LOG: INFO: Timeout fired
19:56:54     INFO - 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidStateError(deleted source) v.s. InvalidAccessError(incorrect source) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidStateError(deleted source) v.s. InvalidAccessError(incorrect direction) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidAccessError(incorrect direction) v.s. InvalidStateError(iteration complete) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidAccessError(incorrect direction) v.s. InvalidStateError(iteration ongoing) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidAccessError(incorrect source) v.s. InvalidStateError(iteration ongoing) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidAccessError(incorrect source) v.s. InvalidStateError(iteration complete) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidStateError(iteration ongoing) v.s. DataError(unset key) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | InvalidStateError(iteration complete) v.s. DataError(unset key) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | DataError(unset key) 
19:56:54     INFO - TEST-PASS | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | DataError(unset primary key) 
19:56:54     INFO - TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | DataError(keys are lower then current one) in 'next' direction - Test timed out
19:56:54     INFO - 
19:56:54     INFO - TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | DataError(keys are larger then current one) in 'prev' direction - Test timed out
19:56:54     INFO - TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | expected OK
It seems that the test time for 13 indexeddb_tests in this file is to close to the timeout(10 seconds). I should either extend the timer or separate them into multiple files.
Assignee: nobody → btseng
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
The Testharness.js API allow us to set the harness timeout from "normal"(10 secs) to "long"(60 secs).
http://testthewebforward.org/docs/testharness-library.html#harness-timeout
However, this seem not working in our test harness integeration:
The timeout is still in 10 seconds even I add the <meta> tag in the test:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f861207be306&selectedJob=26657883
In addition, when testing in my local computer the timeout is always set to 30 seconds no matter the <meta> tag is added or not.
In addition,
if I set up web-platform-test locally according the the guideline in
https://github.com/w3c/web-platform-tests
, then the <meta> tag is effected. :(
Blocks: 1300027
No longer blocks: 1300027
Depends on: 1300027
See bug 1300027 comment 3:
"
The manifest needs "timeout": "long" specified for the test or the harness will set the default timeout despite the <meta> tag (search for existing instances). --manifest-update should regenerate the manifest adding this test with the extra information to the local_changes section.
"

The harness has to know about the timeout before starting the test, so it has to go in the manifest.

We should run |mach web-platform-tests --manifest-update| again after modifying the <meta> tag of the test case.
Root cause:
1. All 13 indexeddb_tests in idbcursor-continuePrimaryKey-exception-order.htm are related to the exception order of IDBCursor.continuePrimaryKey() and takes about 10 seconds for the testing.
2. The default timeout of a web-platform-test is set to 10 seconds.

Solution:
1. specifying the <meta> tag to extend the timeout from normal to long according to the web-platform-test API in [1].
2. Additional configuration in MANIFEST.json is required to apply the timeout correctly for our test harness as explained in comment 5.

We can see the 60-second timeout takes effect in the treeherder result:
https://treeherder.mozilla.org/logviewer.html#?job_id=26921547&repo=try#L3815
> 19:07:53 INFO - TEST-INFO took 60156ms

[1] http://testthewebforward.org/docs/testharness-library.html#harness-timeout
Attachment #8788027 - Flags: review?(jvarga)
Comment on attachment 8788027 [details] [diff] [review]
(v1) Patch: Extend the harness timeout from "normal" to "long".

Review of attachment 8788027 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Attachment #8788027 - Flags: review?(jvarga) → review+
Duplicate of this bug: 1294044
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | DataError(keys are lower then current one) in 'next' direction - Test timed out → Intermittent TEST-UNEXPECTED-TIMEOUT | /IndexedDB/idbcursor-continuePrimaryKey-exception-order.htm | expected OK
Duplicate of this bug: 1299717
Duplicate of this bug: 1300252
Duplicate of this bug: 1300387
Duplicate of this bug: 1297640
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/71bc393f6890
Extend the harness timeout from "normal" to "long". r=janv
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/71bc393f6890
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.