If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dnsNotFound error message on error pages (as well as other messaging) should say "Internet" rather than "Web"

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
a year ago
3 months ago

People

(Reporter: 21Naown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Related to: https://bugzilla.mozilla.org/show_bug.cgi?id=1296921

https://transvision.mozfr.org/?recherche=browser%2Fchrome%2Foverrides%2FnetError.dtd%3AdnsNotFound.longDesc&repo=release&sourcelocale=en-US&locale=fr&search_type=entities&perfect_match=perfect_match

The source string should be "Internet" instead of "Web", because for example, the protocol FTP is not part of the Web, and this message appears for this protocol.

Comment 1

a year ago
(In reply to 21Naown from comment #0)
> the protocol FTP is not part of the Web

If it wasn't, we would have removed it from Firefox by now, as we've done with gopher support. Unfortunately, http(s) webpages somewhat routinely include or link to resources retrieved over FTP.

I think the phrasing here was deliberate, and has been here for over 10 years (!), as part of bug https://bugzilla.mozilla.org/show_bug.cgi?id=301208 and friends. So, closing as wontfix.

If you feel very very strongly this decision is wrong, consider emailing firefox-dev ( https://wiki.mozilla.org/Firefox/firefox-dev ).
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Translation → General
Resolution: --- → WONTFIX
Summary: dnsNotFound → dnsNotFound error message on error pages (as well as other messaging) should say "Internet" rather than "Web"
(Reporter)

Comment 2

3 months ago
When you wrote your comment, I sent a message to firefox-dev. Ignored until now because I sent it again and the results are "it is not the right place" + "minor problem". Well. The definition and comparison about Web and Internet are still the same since this bug report, FTP is not part of the Web but of the Internet.

To change only a single word, it will not take long, and there is no reason to think about "it is a good choice or not?" since this word is covered by a definition. In addition, many sites explain the differences.

Also, I checked your link, the word "internet" is non-existent, so at least here there is no questioning about this. But it should not even have questioning about this.
You need to log in before you can comment on or make changes to this bug.