Crash in mozalloc_abort | abort | vmwgfx_dri.so@0x63b99e , start up crash on Ubuntu16.04 64bit VM

RESOLVED WONTFIX

Status

()

P3
critical
RESOLVED WONTFIX
2 years ago
4 months ago

People

(Reporter: alice0775, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug, {crash, regression, reproducible})

51 Branch
x86_64
Linux
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51- fix-optional, firefox52 fix-optional)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-63537725-dc99-461a-ae5e-8fd6d2160828.
=============================================================

Steps To Reproduce:
1. VMware Workstation 12 Player
   Host OS: Windows10 64bit
   Guest OS: Ubuntu16.04 64bit LTS
2. Start Nightly

Actual Results:
Instant crash


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c807d56a4f2175493cb865ff1a3968f1a978b44e&tochange=32fd2e8a3be820c0a8c9d2210e6cfae990a561d8

Regressed by: Bug 594876
(Reporter)

Comment 1

2 years ago
FYI, Nightly51.0a1 works properly on Ubuntu16.04 32bit LTS.

So, It seems to affect only Ubuntu16.04 64bit LTS.

Updated

2 years ago
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
(Reporter)

Comment 2

2 years ago
How I can disable OpenGL?
If not, please backed out the offending Bug 594876 because Nightly51 crashes under VM.
Flags: needinfo?(andrew)
(In reply to Alice0775 White from comment #2)
> How I can disable OpenGL?

You can set the environment variable MOZ_ACCELERATED to 0.

> If not, please backed out the offending Bug 594876 because Nightly51 crashes
> under VM.

It's more likely that we'll just blacklist away vmwgfx. I'll look into this some more.
(Reporter)

Comment 4

2 years ago
Thanks. Nightly51 works as expected when the environment is defined.
Do you mind seeing if setting the environment variable MOZ_DISABLE_CONTEXT_SHARING_GLX to 1 resolves your issue? While I have yet to get VMWare player patched for my kernel version, many of the stacks indicate that the issue could be occurring when attempting to claim the shared GL context.
Flags: needinfo?(andrew) → needinfo?(alice0775)
(Reporter)

Comment 6

2 years ago
(In reply to Andrew Comminos [:acomminos] from comment #5)
> Do you mind seeing if setting the environment variable
> MOZ_DISABLE_CONTEXT_SHARING_GLX to 1 resolves your issue? 

Setting MOZ_DISABLE_CONTEXT_SHARING_GLX=1 also fixes the crash.
Flags: needinfo?(alice0775)
Un-track for 51 as the volume of crash number is very low.
tracking-firefox51: ? → -
Hi :acomminos,
Do you have any updates per comment #6?
Flags: needinfo?(andrew)
Not yet, sorry.

Leaving the needinfo flagged as I hope to get VMWare player set up soon to find out whether GLX context sharing is buggy on vmwgfx, or if our paths for it are triggering another issue.

FWIW, this crash only affects Nightly by default (we don't enable GL composition on Linux on other channels yet).

Updated

2 years ago
Whiteboard: [gfx-noted]
Bulk move of gfx-noted bugs without priority to P3 for tracking.
Priority: -- → P3
Bug 1288491 should probably be duped against this one, since it seems to have more information.
Duplicate of this bug: 1288491
(Reporter)

Updated

2 years ago
status-firefox52: --- → affected
status-firefox51: affected → fix-optional
status-firefox52: affected → fix-optional

Comment 13

10 months ago
Does it still happen?
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.