videoElement loses textTracks after DOM manipulation

RESOLVED DUPLICATE of bug 1242594

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1242594
2 years ago
2 years ago

People

(Reporter: distler, Assigned: bechen)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

920 bytes, text/html
Details
(Reporter)

Description

2 years ago
Created attachment 8785732 [details]
Testcase

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120191716

Steps to reproduce:

See the testcase.


Actual results:

videoElement.textTracks.length changes from 2 to 0 after DOM manipulation.


Expected results:

Moving the video element should preserve its textTracks.

Updated

2 years ago
Component: Audio/Video → Audio/Video: Playback
Lets mark this as a P1 because it appears to be broken.
Priority: -- → P1
(Assignee)

Updated

2 years ago
Assignee: nobody → bechen
(Assignee)

Comment 2

2 years ago
Latest nightly pass the testcase. And I believe I had fix it, bug 1242594.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242594
You need to log in before you can comment on or make changes to this bug.