pulse_actions - Retrigger on jobs that have been added as new jobs does not work

RESOLVED WONTFIX

Status

Testing
General
RESOLVED WONTFIX
2 years ago
10 months ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

See https://treeherder.mozilla.org/#/jobs?repo=try&revision=eeff902b54fe&group_state=expanded

What I did was do a try push, and then used "Add jobs" to add the Windows M-e10s-4 job. The first instance of that was green. Some time later, I retriggered that job by mashing "r" with it selected - all of those retriggers failed. I'm not sure if this is a bug with taskcluster, or with the retriggering of the job, or something else.

Comment 1

2 years ago
The jobs want to download the following [1], however, that task does not exist [2]
I see that the task ID comes from the previous job [3]

This is probably a bug in my original Mozharness code to make this magically work [4]

I will grab this.

[1] https://queue.taskcluster.net/v1/task/DJ7PsagUS7u_4HFIZ6pPhA
[2]
{
  "code": "ResourceNotFound",
  "message": "DJ7PsagUS7u_4HFIZ6pPhA does not correspond to a task that exists.\nAre you sure this task has already been submitted?\n----\nerrorCode:  ResourceNotFound\nstatusCode: 404\nrequestInfo:\n  method:   task\n  params:   {\"taskId\":\"DJ7PsagUS7u_4HFIZ6pPhA\"}\n  payload:  {}\n  time:     2016-08-29T16:15:15.926Z\ndetails:\n{\n  \"taskId\": \"DJ7PsagUS7u_4HFIZ6pPhA\"\n}",
  "requestInfo": {
    "method": "task",
    "params": {
      "taskId": "DJ7PsagUS7u_4HFIZ6pPhA"
    },
    "payload": {},
    "time": "2016-08-29T16:15:15.926Z"
  },
  "details": {
    "taskId": "DJ7PsagUS7u_4HFIZ6pPhA"
  }
}
[3]
15:02:10     INFO - Using buildbot properties:
15:02:10     INFO - {
15:02:10     INFO -     "upload_to_task_id": "b57hFLJ3S7KcUSRAwHKfFg", 
15:02:10     INFO -     "project": "", 
15:02:10     INFO -     "product": "firefox", 
15:02:10     INFO -     "who": "kgupta@mozilla.com", 
15:02:10     INFO -     "script_repo_revision": "production", 
15:02:10     INFO -     "taskId": "DJ7PsagUS7u_4HFIZ6pPhA", 
15:02:10     INFO -     "repository": "", 
15:02:10     INFO -     "buildername": "Windows 7 VM 32-bit try debug test mochitest-e10s-4", 
15:02:10     INFO -     "stage_platform": "win32", 
15:02:10     INFO -     "basedir": "C:\\slave\\test", 
15:02:10     INFO -     "buildnumber": 446, 
15:02:10     INFO -     "platform": "win32", 
15:02:10     INFO -     "parent_task_id": "bb9d-IadRCSuCY6-gyXyKg", 
15:02:10     INFO -     "master": "http://buildbot-master140.bb.releng.usw2.mozilla.com:8201/", 
15:02:10     INFO -     "slavebuilddir": "test", 
15:02:10     INFO -     "branch": "try", 
15:02:10     INFO -     "revision": "eeff902b54fe6a215aecbade7165a6729d5ad8ed", 
15:02:10     INFO -     "moz_repo_path": "", 
15:02:10     INFO -     "slavename": "t-w732-spot-536", 
15:02:10     INFO -     "repo_path": "try"
15:02:10     INFO - }
[4]
https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/mozharness/mozilla/testing/testbase.py?q=Finding+installer%2C+test+and+symbols+from+parent+task&redirect_type=single#333
Assignee: nobody → armenzg
Component: General → Mozharness
Product: Taskcluster → Release Engineering
QA Contact: jlund
Summary: Retrigger on Windows 7 VM debug mochitest-e10s-4 fails with python error → Retrigger on jobs that have been added as new jobs does not work

Updated

2 years ago
Assignee: armenzg → nobody
Component: Mozharness → General
Product: Release Engineering → Testing
QA Contact: jlund
Summary: Retrigger on jobs that have been added as new jobs does not work → pulse_actions - Retrigger on jobs that have been added as new jobs does not work

Comment 2

10 months ago
Shutting pulse_actions off (see bug 1379172).
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.