Thunderbird not properly hanlding '4.7.0 Temporary System Problem' from gmail smtp server. And message gets saved to Sent folder, when it wasn't sent.

RESOLVED DUPLICATE of bug 780124

Status

MailNews Core
Networking: SMTP
RESOLVED DUPLICATE of bug 780124
a year ago
9 months ago

People

(Reporter: Nathan Neulinger, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36

Steps to reproduce:

Attempt to send mail via smtp.gmail.com


Actual results:

Dialog displayed saying "4.7.0 Temporary Ssytem Problem. Try again later" from gsmtp. This part is obviously google's issue, the problem is that thunderbird just treats the message as sent - even though it's never actually getting sent. The message DOES get saved to sent items. It looks like thunderbird is not properly treating the error as a 'failed to send message'.

Note - this appears to have some similarities to 780124 but seems distinct enough that I submitted a distinct bug report. 

Testing on ub 16 with vendor packaging. I can update to earlybird if needed to test further. 


Expected results:

Either compose window should have stayed open, or the message should have gone into outbox of some sort to be retried.

Updated

a year ago
Blocks: 780124
Component: Untriaged → Networking: SMTP
Product: Thunderbird → MailNews Core
Summary: Thunderbird not properly hanlding '4.7.0 Temporary System Problem' from gmail smtp server → Thunderbird not properly hanlding '4.7.0 Temporary System Problem' from gmail smtp server. And message gets saved to Sent folder, when it wasn't sent.
Version: 47 Branch → 47
(Reporter)

Comment 1

a year ago
This is still an issue. Failures to send mail appear to be treated as successful sends and the message just goes into the ether.

Comment 2

10 months ago
This problem is happening to me with frequency. My company uses a Microsoft Exchange cloud based server and it frequently replies with a 4.4.2 error and the message is not sent, instead of being queued. People using other mail clients dont experience any problems.

Does setting mailnews.sendInBackground to true will have influence in this problem?

Comment 3

9 months ago
> Does setting mailnews.sendInBackground to true will have influence in this problem?

I don't think so. Have you tried it?

Incorrectly saving to folder is bug 780124
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780124
You need to log in before you can comment on or make changes to this bug.