On just about any web page, images and links are often off by one pixel

RESOLVED FIXED in Future

Status

P2
normal
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: s3225202, Assigned: kmcclusk)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
Moving the mouse of images and links (try links further to the left of the
screen) makes the jump 'across one pixel' where they settle.
This is most annoying to look at. You'd expect the system to draw it correctly
in the first place.

The second sympton of this is that sometimes the fonts are drawn with half of
their height 'off by one pixel' which makes them look a little italic. Double
clicking on them to select the text forces them to re-draw in the correct way.

The fact that it's fonts and images suggests to me that it isn't my font server
causing the rendering problem.

Comment 1

17 years ago
build ID=?

the font issue sounds like bug 122577.  there might also be a bug for the
images, but I don't see it now.
(Reporter)

Comment 2

17 years ago
The splitting of the fonts so that half of it is off by one pixel can happen
inside a table cell, independant of the line it's on. I witnessed this just tonight.
(Reporter)

Comment 3

17 years ago
After reading bug122577 I think these are definately different. I get this
drawing problem -constantly-. And only sometimes can scrolling it off the visual
area and back again can fix it.
Very rarely does it help in fact.

If you select the text by dragging the mouse with the button down, it always
redraws the area being selected. In the process of doing so, it shifts the fonts
around. Moving the mouse over links that have a hover style also forces the
fonts to redraw. Clicking on an image, even if it's not a link causes it to redraw.

Every time these things redraw they shift by 1 pixel to the left.

More interestingly, on slashdot.org, I dragged my mouse from the middle table
area (the section where the stories are) and the text re-aligned itself, then I
kept dragging in to the left frame and that section re-aligned itself, but the
middle table area un-realigned itself! - which suggests to me that the
positioning code adjustments made by tables is getting confused.
(Reporter)

Comment 4

17 years ago
My System is Debian Linux. I've seen this in Mozilla builds 0.9.6, 0.9.7, 0.9.8
and now 0.9.9. I'm using the closed source NVidia drivers with XFree 4.1.
(Reporter)

Comment 5

17 years ago
I just saw an example of an image being 'split' with part of it offset and part
of it not-offset, just like the fonts do.

Also, the font problems (and now image problems) where the font/image is 'split'
can be fixed by scrolling them off the screen, or clicking on them (to force the
engine to redraw them).

As the other bug says, you can some time cause this by using the mouse wheel,
but it's not exclusively a mouse wheel problem. The page can sometimes start
rendered that way.

Also, moving windows over images will sometimes leave white lines over the image
as if the rendering engine wasn't watching careful what areas it should be
redrawing.

I use Enlightenment as my Window Manager.
(Reporter)

Comment 6

17 years ago
I believe that bug 122577 and this bug are actually related. But not quite in
the way I originally thought they might.

This bug covers more than bug 122577. Basically, once a page is rendered, it may
get certain areas of the page placed off by 1 pixel. If you move another window
over the mozilla window, areas that were covered may be re-drawn 1 pixel off. If
you swap tabs, sections of the page may be re-drawn 1 pixel off. If you use the
mouse wheel up and down the re-revealed sections may be 1 pixel off.

It affects more than just the fonts, but also images too. I'm not sure if it is
only images that are links, or images in general.

It also links in to the problem with images breaking up when you drag other
windows over them or scroll the page.

It's a general drawing/redrawing bug.
(Reporter)

Comment 7

17 years ago
Bug 121920 and Bug 94739 talk about changing the font size to fix the problem.
I just checked to see if changing the font size would solve the problem for me.
Unfortunately, it did not.
(Reporter)

Comment 8

17 years ago
Created attachment 74711 [details]
the page after initial rendering

This is a rendered page on my system without using tabs or anything
particularly special. It demonstrates that the large bolded text is 1 pixel
further to the right than it should be
(Reporter)

Comment 9

17 years ago
Created attachment 74712 [details]
The same page, after selecting the bolded text and deselecting it

This is the same page, just after it is rendered. I double clicked on the
bolded text 'How' and that entire bolded line shifted itself across to the left
by 1 pixel. This image demonstrates that. Swap back and forth between the two
images in Xv or some other image program to see it in action.
(Reporter)

Comment 10

17 years ago
Created attachment 74921 [details]
watch slashdot.org jiggle

Here are a couple of shots from the website slashdot.org demonstrating the
problem.

First image is how the page load
Second image is after selecting some of the first story (note the missing :
after 'chill writes' in the second story)
Third image is after selecting some more of the first story
Fourth image is after selecting some of the header of the first story
Fifth image is after selecting the title of the first story (note the green
area now has a broken left hand border)
Sixth image is after selecting the left hand table column (note, everything
jumps back to how it was after the page had loaded)
Seventh image is after selecting nothing. Note we are now back to square one.
-Except that things are actually better drawn than the original render (note,
the : on the second story is now there.)

Use 'Xv' or something to cycle through the images and watch the page jiggle :)
(Reporter)

Comment 11

17 years ago
Many additional comments have been added to this bug. I'd like to have it
re-reviewed by QA please.
(Reporter)

Comment 12

17 years ago
Created attachment 74936 [details]
animation sequence for the previous 7 images - requires GIMP

This is an animation created from the previous seven images to illustrate the
point a little more. It's .tar.gz so you'll need to expand it. The file is an
.xcf which is a GIMP format - since I can't create animated gif's.
There is an option in my GIMP called Filters->Animation->Animation Playback
which I used to show the animation on my own computer.
I hope this helps a little more :)
probably one of our twips-to-pixel rounding bugs.
Assignee: asa → kmcclusk
Status: UNCONFIRMED → NEW
Component: Browser-General → GFX Compositor
Ever confirmed: true
QA Contact: doron → petersen
Whiteboard: DUPEME

Updated

17 years ago
Blocks: 134942
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: --- → Future
(Assignee)

Comment 14

17 years ago
I recently checked in a fix for bug 80530. Which fixed this problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.