Closed Bug 1299204 Opened 5 years ago Closed 5 years ago

Force GC/CC in reftests since we can't figure out why nothing works

Categories

(Core :: JavaScript: GC, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: terrence, Assigned: terrence)

References

Details

Attachments

(1 file)

This is a last resort. Things that fix the problem for me locally time out on try and hacks that hide the problem on try quadruple my test times locally. Hopefully just forcing a GC/CC occasionally will keep the overheads low enough that tests can at least complete everywhere while we investigate the root cause. At least, it worked for me when I tried it a month ago.
Attachment #8786396 - Flags: review?(mchang)
Comment on attachment 8786396 [details] [diff] [review]
force_gc_cc_in_reftests-v0.diff

Review of attachment 8786396 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/tools/reftest/reftest-content.js
@@ +45,1 @@
>  

nit: add a comment saying this runs for both the content and parent process. We had a comment in the other CC bug. Thanks!
Attachment #8786396 - Flags: review?(mchang) → review+
https://hg.mozilla.org/mozilla-central/rev/4558fc3a7120
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
See Also: → 1300355
You need to log in before you can comment on or make changes to this bug.