reDesign the User Interface, to get a coherent comunication between the user and Mozilla.

VERIFIED WONTFIX

Status

SeaMonkey
General
--
enhancement
VERIFIED WONTFIX
16 years ago
14 years ago

People

(Reporter: Lancer, Assigned: Matthew Paul Thomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Taking by example this:
in Navigator menu bar: 'back', 'forward', 'reload', 'stop', 'Open Web
Location...'; all are into diferents menus.

I maditate it more than one time and i still dont see any sense of have all this
options into diferents menus... has no logic.

-'open web location...': the navigator doesnt render all the kinds of file. So
¿why da hell is this option into the File menu??!!! would someone please explain
me that?.
The navigator is made for render web documents, which has links to other web
documents; there the meaning of the name "navigator". A *.jpg or *.txt file
doesnt has links.

-'Back', 'forward', 'home': ...oh my God. These are under a menu called 'go'. I
dont know in yours, but in my mozilla the same two letters("g" and "o") appears
into a button at the right of the address box(in the navigation toolbar); and
this button make mozilla go to the web location wrote in the address box. If i
write the word 'forward' into that address box and then a click the button 'go',
mozilla try to find "www.forward.com", and that is not the same thing that
mozilla do when i click 'forward' into the go menu. again Can someone explain me
that?.
The 'home' option is just a shortcut, a bookmark... ...what is it doing into a
menu with 'back' and 'forward' options???

'Reload', 'Stop': Are into the same menu where is placed options to show and/or
hide toolbars... I guess that is enough to explain the no-sense with these.


Since i been using mozilla(about one and a half years) i have found a lot of
bugs in the user interface (I was an Architectural studient and actually i work
in the Graphic Design ambient).
The User Interface is the language used by the application, for the comunication
with the user. If this language has no coherence, the comunication between the
user and the application turn into something dark which moves away the user from
the application. The good aplications are good not only because are efficient
fast or compatibles... etc. One of the principal reasons which makes an
application good is its user interface.
I tell you this because i have a long experience using OS(from TOS to MS
Windows) and aplications; and because i know the meaning of the word "language".
I will give you the perfect example, Photoshop. Is in the top and has its
prestige not for be an easy to use aplication or for its features. The
Photoshop's language of comunication with the user, make it a graphic design
application and not another kid toy.

Comment 1

16 years ago
There are already bugs covering this, although the only one that comes to mind
is bug 69555.  Also, please read the bug reporting guidlines at
http://www.mozilla.org/quality/bug-writing-guidelines.html.  Try to keep your
bug reports more concise instead of rambling so much;  the developers are more
likely to listen.

Comment 2

16 years ago
Changing summary from:
the bigest bug of Mozilla I guess.
to:
Back, Forward, Reload, Stop, Open Web Location... are in differents menus
Sev: cri -> nor
Severity: critical → normal
Summary: the bigest bug of Mozilla I guess. → Back, Forward, Reload, Stop, Open Web Location... are in differents menus
(Reporter)

Comment 3

16 years ago
Changing summary from:
Back, Forward, Reload, Stop, Open Web Location... are in differents menus
to: Rebuild of the User Interface Language
Summary: Back, Forward, Reload, Stop, Open Web Location... are in differents menus → Rebuild of the User Interface Language

Updated

16 years ago
Severity: normal → enhancement

Comment 4

16 years ago
This should be marked as a duplicate of bug 108099.

Comment 5

16 years ago
Marking as DUPE.

*** This bug has been marked as a duplicate of 108099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Lancer, XUL won't be rewritten just because a menu should in your opinion be at
a different location. Thus, "Back, Forward, Reload, Stop, Open Web Location...
are in different menus" should be the right summary. Anyways, this is a dupe.
(Reporter)

Comment 7

16 years ago
I guess this is going to be funny...


    >------------/ I AM NOT TALKING ABOUT PROGRAMING /------------<



I am opening this bug, not because  ...""i'd like to have a HOME button besides
the navigations buttons in the navigation toolbar, because i miss it"" ...as i
did read in a mozilla newsgroup mail. I am not joking, i talking seriuslly.



You can make what you think is right with XUL. What i am trying to explain with
that ONE example i gave, that there is a Big thing into Mozilla which doesnt
seems to have a real, serius and deep work. I am talking about the LANGUAGE(not
xul) of its user intarface. I am talking about the comunication between the
browser and the user.

Mozilla actually use a language in its user interface which seems to has been
built based on the others render aplications of webdocuments; and not based on
what it perform:

http://bugzilla.mozilla.org/attachment.cgi?id=57968&action=view



Personally i think this can be the first big change immediatly possible to do,
before the 1.0 be released (...well i dont know how much possible it is): To
reorder all the options of the menu bar and change some names too. I mean a BIG
change.

This is not an opinion. I guess this is necessary for make of Mozilla Browser
not an aplication which only pretend to be fast compatible and efficient;
because Mozilla will be, wanted or not, fast, compatible and efficient.
Then the only thing left, is go to a next step: make of Mozilla an Authentic,
Mature and Evolved Aplication. And the start point for this, is to build a
COHERENT LANGUAGE for its user interface. And not one based on the actuals and
wrong standars.



The 99% of the people who report bugs about make changes on toolbars, menus or
things like that, do it just because they think...  ""i'd like to have a HOME
button besides the navigations buttons in the navigation toolbar, because i miss
it"".
I believe this is not one of those cases. Please read the bug one more time, and
think again about to mark this as duplicate bug. Because that thing about 'back'
'forward' 'reload' 'sto... was an example; the meaning of this bug is more
bigest than only make menu changes.



· ¡And dont forget to visit latinmoz! http://latinmoz.f2g.net/ ·
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 8

16 years ago
Nothing from your elaboration changes the fact that this is a duplicate of bug 
108099 (nominated for 1.0). Please read the details of that bug more closely, 
and move your comments there. bug 108099 is about the complete restructuring of 
the mozilla menu system. In addition, there are 14 dependencies and 5 blockers 
that all cover the same general area. In other words, there is no need for a 
bug report as wide ranging as this one. Further discussion should take place in 
a suitable newsgroup.
Please read the bug reporting guidelines as suggested: 
http://www.mozilla.org/quality/bug-writing-guidelines.html 
Reports should be clear, concise and focussed on one particular issue. 
Everyone else - sorry for the spam!


*** This bug has been marked as a duplicate of 108099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
I am having an extremely difficult time understanding what you are trying 
to say even after reading the bug report 4 times over, but this 'language' 
thing is confusing everybody. I'm rewording the summary, but I'm sure that 
I missed something because I can't understand the bug report. We refer 
to a User Interface Language as XUL which is the core programming xml-
based toolkit that defines the user interface. In bugzilla, please don't just 
file general "fix the UI bugs," because that doesn't help. One bug per 
problem please.

Next time you report bugs, please use the Bugzilla Helper at http://
www.mozilla.org/quality/help/bug-form.html.

Thanks for using mozilla and reporting bugs,

Zach
User Interface Design QA
I'm almost certain that the word he is searching for is rather "Interface", e.g.
he refers to HIG's (Human Interface Guidelines). Note that he isn't a native
English speaker (I'm not either).

I still think this is a dupe though.
(Reporter)

Comment 11

16 years ago
Changing summary from:
Rebuild of the User Interface Language
to: reDesign the User Interface, to get a coherent comunication between the user
and Mozilla.
Summary: Rebuild of the User Interface Language → reDesign the User Interface, to get a coherent comunication between the user and Mozilla.
(Reporter)

Comment 12

16 years ago
Please read what i have wrote here:

http://bugzilla.mozilla.org/show_bug.cgi?id=108099#c23
Lancer, this bug is "RESOLVED DUBPLICATE". Either REOPEN it (with giving a
reason why), or leave it.
(Reporter)

Comment 14

16 years ago
What i am suggesting is to do a lot of diferent changes with the intention of
reorder Mozilla.

Mozilla in about 5 years has became a completely diferent program. And even when
i still feel mozilla slow, i believe that the user interface has not to be only
the fact that mozilla can be skinned     ...!

The user interface IS and has to take a more bigest important. As i said, i
believe wanted or not, mozilla is going to be fast, compatible and efficient
enough. So the next step is give to the user an intelligent, an evolved user
interface.

I guess i am talking about design. All the current aplications are the
following, and they has nothing more to offer:

> WINDOWS
> TITLEBARS
> SCROLLBARS
> '¡%&#·ING  TOOLBARS
> BUTTONS
> MENUS WHICH ORDER OF ITS OPTIONS IS INCREDIBLY INCOHERENT
> '%&¡#·ING  SECONDARY CLICK MENUS WHICH APPEAR IN ALL PLACES GENERATING MORE TRASH
> ETC.


Honestly, since i use computers, i had never, never, NEVER like all this stuff,
but the menus. And this is not a personal point of view, is the point of view of
an Architect.
They are not starndards. They doesnt give a coherent language. They are '%&¡#· . 

Please, read carefuly this bug:

http://bugzilla.mozilla.org/show_bug.cgi?id=130798

I suggest have many bugs like that, and have this to talk about each one of
those and how they are going to be integrated in mozilla.
Not a talk about code or programing, a talk about the design of the user
interface, the visual design; where resides the language of comunication with
the user.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 15

16 years ago
we will *not* fix this the way you want it fixed. resolving as wontfix. UID qa 
has already duped, there is no way you'll get what you want. please stop 
wasting our time. Instead post to the newsgroups until the cows come home.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 16

16 years ago
..."please stop wasting our time"...
I took my time to give you the oportunity of FIX MOZILLA.

I Dare you, you are not going anywhere. Anyone, like Opera and/or Microsoft,
move ONE finger and ALL mozilla is history, FIVE YEARS OF WORK GO TO TRASH.

bye.
(Reporter)

Comment 17

16 years ago
I cant wait to see 1.0...

Is going to be so fun!
Severity: enhancement → blocker
Target Milestone: --- → M1

Comment 18

16 years ago
v=aha
Severity: blocker → enhancement
Status: RESOLVED → VERIFIED
Target Milestone: M1 → ---

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.