Brocade switch explorer no longer works in Ver 48

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: jhorner, Unassigned)

Tracking

48 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

I attempt to connect to the Brocade fiber switch at a given IP address.


Actual results:

A second tab opens with a rapidly flashing message at the bottom of the screen saying "Looking up jdl.sun.com". I am never prompted with the Java window. I uninstalled Ver 48.0.1 and installed Ver 47.0.1 and it works normally again.


Expected results:

I should have been prompted as to which version of Java I want use (1.7.0_67 or 1.8.0_101).
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Given that the page is not publicly accessible, it's hard to reproduce or investigate the issue from other place.

Does the issue happen on safe mode and clean profile?
If so, can you find out which change introduced the issue, by using mozregression tool?
http://mozilla.github.io/mozregression/
Flags: needinfo?(jhorner)
I came back after a holiday, run and upgrade of my ubuntu VM I use to manage SAN and Storage devices and got Firefox updated to 48.0... 
since then I cannot start the Brocade WEB Tools interface: it behaves as described by jhorner.

I'd like to take it back to 47.0.1... I'll have to find out how to do it in ubuntu... 

I'll let you know about my findings.
(Reporter)

Comment 3

2 years ago
The issue still happens in safe mode and a clean profile.

I am working on the regression tool.

I did find a work around: If you add "_installed" to the saved URL, the Java applet will load. Example:
http://IPAddress/switchExplorer_installed.html
Your work around is a blessing and works well!!! 
I borrowed a Chrome and a Opera browser from a colleague and they both show the same problem... all of them loop trying to get to jdl.sun.com (which, by the way, loops also when browsed plain and straight).
We also tried from a IE but, "regrettably", it did not loop, just gave a message and carried on.
Firefox 47 worked... as you told before. 
I cannot do much more problem determination because the VMs from where we tested aren't mine, but if we can help with some tests or other info, just let me know and I'll see how we can do. 

I'm following this closely. 
Thanks again for your prompt reply!
Flags: needinfo?(jhorner)
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160901030202

As Tooru mentioned, this page is not publicly accessible and it is hard to investigate this issue. You could use mozregression tool (http://goo.gl/UZBD72) to investigate this issue. If the issue is happening as you say, in mozregression you can set a bad build and a good build and discover the source of the issue. Please do a regression range with mozregression and post the pushlog in a comment.
Thank you.
Flags: needinfo?(jhorner)
Flags: needinfo?(faustria)
Marking this as Resolved-Incomplete due to the lack of response from the reporter.

If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jhorner)
Flags: needinfo?(faustria)
Resolution: --- → INCOMPLETE

Comment 7

2 years ago
Created attachment 8805795 [details]
HTML and Javascript Code

This is the code that now loops.
You need to log in before you can comment on or make changes to this bug.