Recent changes introduced by bug 1294478, flags do not display on the enter_bug.cgi page

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dkl, Assigned: dkl)

Tracking

({regression})

Production
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
JS code in create.html.tmpl expects an Array object of flag type ids when deciding which flags are displayed. enter_bug.cgi is creating a comma delimited string instead and JSON.parse does not convert it to an Array object.

Patch coming.

dkl
(Assignee)

Comment 1

2 years ago
Created attachment 8786468 [details] [diff] [review]
1299280_1.patch
Attachment #8786468 - Flags: review?(dylan)
Comment on attachment 8786468 [details] [diff] [review]
1299280_1.patch

r=dylan

embarrassing mistake. This passed local testing due to a tragedy of errors involving mod_perl.
Attachment #8786468 - Flags: review?(dylan) → review+
(Assignee)

Comment 3

2 years ago
To https://github.com/mozilla-bteam/bmo.git
   2d12418..cd6e139  master -> master
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.