[e10s] Scrolling on touch enabled Laptop creates lag in rendering/paint on print preview page

RESOLVED DUPLICATE of bug 1256677

Status

()

Core
Panning and Zooming
P3
normal
RESOLVED DUPLICATE of bug 1256677
a year ago
a year ago

People

(Reporter: Kanchan Kumari QA, Unassigned)

Tracking

51 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(e10s+, firefox51 affected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
Scrolling on touch enabled Laptop creates lag in rendering/paint on print preview page

[Tested Version]: 
Build Id 20160830030201
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[Tested touch enabled platform]: 
Surface Pro 4  
Aspire SW3-013

[Pre-requisite]: 
javascript.options.asyncstack; false
browser.tabs.remote.force-enable; true
browser.tabs.remote.autostart.2; true 
layers.async-pan-zoom.enabled; true 
About:support
Multiprocess Windows 1/1 (Enabled by user)
Asynchronous Pan/Zoom wheel input enabled;

[Steps to reproduce]:
1. Navigate to a webpage. (eg: https://en.wikipedia.org/wiki/peach )
2. Use your finger to tap the Menu.
3. Press "Print".
4. Scroll up/down on print preview page using fingers. 

[Expected result]:
No rendering or crash issue.

[Actual result]:
scrolling creates a delay in rendering/paint. Tab and Firefox browser crash

[Note]:
Scrolling fast make this issue more prominent(see in attachment).
With above STR I got three tab crashes "Bad news first: This tab has crashed" and one browser crash. This is e10s specific.

Crash Report:
bp-bb6d8eae-2853-4c90-87a6-ffba52160830 48 minutes ago
bp-ac07aabb-058c-4aba-805e-b294f2160830 48 minutes ago
bp-1b838058-3c75-4660-a8b6-759232160830 50 minutes ago
bp-b68904c9-4320-4184-82d9-63d722160830 52 minutes ago
(Reporter)

Updated

a year ago
tracking-e10s: --- → ?
(In reply to Kanchan Kumari QA from comment #0)
> Scrolling fast make this issue more prominent(see in attachment).

Which attachment?

> Crash Report:
> bp-bb6d8eae-2853-4c90-87a6-ffba52160830 48 minutes ago
> bp-ac07aabb-058c-4aba-805e-b294f2160830 48 minutes ago
> bp-1b838058-3c75-4660-a8b6-759232160830 50 minutes ago
> bp-b68904c9-4320-4184-82d9-63d722160830 52 minutes ago

These crashes are all covered by other bugs - two of these are bug 1298130, one is bug 1298954, and one is the accessibility crashers.

I see that in this one you don't seem to have touch input enabled (your about:support output says wheel input only), so I'm not going to make this block bug 1244402. Probably still needs investigation though.
See Also: → bug 1298954
(Reporter)

Comment 2

a year ago
deleteme
Sorry it couldn't attach last time because of large size. Here is the link https://ranisharma22.tinytake.com/sf/OTQyNjgwXzM5NjU0MzU
(Reporter)

Comment 3

a year ago
Another video of bug: https://ranisharma22.tinytake.com/sf/OTQyNzYyXzM5NjU2NDQ
I couldn't access the link in comment 2 - permission denied. I saw the video in comment 3, and it looks like checkerboarding. However I'll try again to reproduce locally and confirm. Also in the about:support in the video it showed that touch input was enabled, which contradicts what you said in comment 0.
Blocks: 1244402
Priority: -- → P3
Whiteboard: [gfx-noted]

Updated

a year ago
tracking-e10s: ? → +
Depends on: 1304130
No longer depends on: 1304130
I followed the steps and I can get a little bit of checkerboarding but nothing much. It's transient and goes away almost immediately. Kanchan, do you still see this problem? In particular I'm interested in behaviour that's worse than just a little checkerboarding.
Flags: needinfo?(kkumari)
(Reporter)

Comment 6

a year ago
Hello Kat, I still see this issue. 
https://ranisharma22.tinytake.com/sf/MTAyNzI3OF80MjAwNzcx

Yes, this seems checkerboarding issue as with layers.async-pan-zoom.enabled; false, it's not reproducible.
Flags: needinfo?(kkumari)
Thanks, that does look like regular checkerboarding. I'll dupe this over to the main checkerboarding bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256677
You need to log in before you can comment on or make changes to this bug.