Fix app update test file in use checks

RESOLVED FIXED in Firefox -esr45

Status

()

Toolkit
Application Update
P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
mozilla51
Points:
---

Firefox Tracking Flags

(firefox-esr45 fixed, firefox51 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The check for a process is running in the parallel tests should just be file in use checks since these tests run in parallel.
Created attachment 8786532 [details] [diff] [review]
patch rev1

Try push
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a1e62c2ffb1b
It looks like these changes make it so bug 1214421 happens way more often... which I think is a good thing since it should help with tracking down the cause.
bah... false alarm
Created attachment 8786636 [details] [diff] [review]
patch rev2

Try push
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5f995ca05b8b

Other platforms passed the earlier try push.
Attachment #8786532 - Attachment is obsolete: true
Attachment #8786636 - Flags: review?(mhowell)
Attachment #8786636 - Flags: review?(mhowell) → review+
Priority: -- → P3

Comment 5

a year ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/586deb42b345
test code only - Fix app update test file in use checks. r=mhowell
https://hg.mozilla.org/mozilla-central/rev/586deb42b345
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Pushed (test only changes) to mozilla-esr45
https://hg.mozilla.org/releases/mozilla-esr45/rev/edbad0d3a19a
status-firefox-esr45: --- → fixed
You need to log in before you can comment on or make changes to this bug.