HTMLMediaElement's mozCaptureStream may result in no output

RESOLVED FIXED in Firefox 51

Status

()

P1
normal
Rank:
17
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: pehrsons, Assigned: pehrsons)

Tracking

51 Branch
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
While investigating bug 1299172 I found locally that we in some cases don't setup a captured stream properly. I.e., when mozCaptureStream is called after setting the src, but before metadata has loaded.

This also led to an assert when the src ended or we changed source.
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8786725 [details]
Bug 1299451 - Fix mozCaptureStream() happening after setting src but before having metadata.

https://reviewboard.mozilla.org/r/75648/#review73694
Attachment #8786725 - Flags: review?(rjesup) → review+

Comment 3

2 years ago
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7eac2acb63a5
Fix mozCaptureStream() happening after setting src but before having metadata. r=jesup
Rank: 17
Priority: -- → P1

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7eac2acb63a5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
(Assignee)

Updated

2 years ago
status-firefox50: --- → unaffected

Updated

2 years ago
Blocks: 1298777
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1298777
You need to log in before you can comment on or make changes to this bug.