site works incurrectly

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Georg Wild, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020309
BuildID:    2002030910

When clicking the numbers on http://millionenklick.web.de/, the numbers aren't
shown in the bottom circles and therefore the next actions don't work!

Reproducible: Always
Steps to Reproduce:
1.http://millionenklick.web.de/
2.click number
3.

Actual Results:  Number with X marked

Expected Results:  Number marked and shown in circle

Comment 1

17 years ago
WFM with a current CVS build, Linux.
Dup of bug 129827?

Comment 2

17 years ago
WFM using 200230908 Win2k. I'm getting lots of warning on the JS console, though.
(Reporter)

Comment 3

17 years ago
The error reported by JavaScript Console by clicking a number is:
Error: uncaught exception: Permission denied to call method Window.focus!

Comment 4

17 years ago
Georg, look under edit->preferences->advanced->scripts & windows
"allow webpages to:
 ...
 [ ] Raise or lower windows"

Is that option unchecked?  If so, you have asked mozilla to prevent pages from
using javascript to jump to the front/force other windows to the front.  The
script in the page is attempting to do just that, and then having problems
because mozilla won't let it.
(Reporter)

Comment 5

17 years ago
Well, turning this option prevents this warning, but the site still doesn't work!

Comment 6

17 years ago
WFM with Linux build 20020309.  Note that this probably DOM0 rather than
JavaScript Engine.

I get the "uncaught exception" on mouseover even with the pref enabled, but
X'ing the numbers still works.  I get no errors when I click.

You might have to fire up the JavaScript Debugger to see where it's having a
problem since nobody else is seeing this.
(Reporter)

Comment 7

17 years ago
Well, I looked with Debugger and with it it worked, and now it works without it
again?!?!?!?!? Don't know, why? Maybe I changed something in fonts, maybe it
works because I downloaded a new build 2002031010.

I think we should close this task because it is not reproducable!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Georg: thanks. If the problem occurs again, please reopen this bug -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.