0.29 - 0.42% installer size (linux32, windows8-64, windowsxp) regression on push bd702fa23037799ab4dd266d8a2b59d021f6cfa8 (Thu Aug 25 2016)

RESOLVED WONTFIX

Status

()

Core
JavaScript Engine
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: wlach, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 wontfix)

Details

Bug 1263355 seems to have increased installer size on a number of platforms (by several hundred kilobytes). This isn't an emergency, but I thought I'd file a bug since it's not obvious why this is the case.

--

We have detected a build metrics regression from push bd702fa23037799ab4dd266d8a2b59d021f6cfa8. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  0%  installer size summary windowsxp opt         53543328.5 -> 53769492.83
  0%  installer size summary windows8-64 opt       57545770.75 -> 57773071.08
  0%  installer size summary windowsxp debug       66694903.08 -> 66925550.5
  0%  installer size summary windows8-64 debug     79563960.58 -> 79834847.58
  0%  installer size summary windows8-64 pgo       57871511 -> 58041646.42
  0%  installer size summary linux32 opt           56394272.25 -> 56556170.83

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=2719


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=2719

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Flags: needinfo?(shu)

Comment 1

2 years ago
Maybe it's due to XDR script sizes or something? Is there a per-file breakdown? Not much I can do with just the raw numbers.
Flags: needinfo?(shu)
You can always hit subtests for any line in the alerts page linked above to get details on the individual tests. Though now that you mention that seems to be broken for installer size. :) I'll look into it. The only nugget of information I could get was for linux32, which shows this:

https://treeherder.mozilla.org/perf.html#/comparesubtest?originalProject=mozilla-inbound&originalRevision=181336fdda6625d8ffa5e5764b817cc3da1f9659&newProject=mozilla-inbound&newRevision=bd702fa23037799ab4dd266d8a2b59d021f6cfa8&originalSignature=ba1be56522b3f8dc520262383b4e6afae13b72ad&newSignature=ba1be56522b3f8dc520262383b4e6afae13b72ad&framework=2

It looks like the size of libxul.so jumped by a bunch (about 100k), which might explain the bulk of this change?

Updated

2 years ago
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → affected

Updated

2 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Hi :jlongster,
Not sure if you are right person for this? Can you help shed some light here or help find an owner for this bug?
Flags: needinfo?(jlong)
I am not the right person for this. I do not work on SpiderMonkey or the related bug mentioned above at all.
Flags: needinfo?(jlong)
I think we should just close this as wontfix. A few hundred k in the installer size isn't that big a deal, I filed the bug in case something jumped out against the original committer.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 years ago
status-firefox51: affected → wontfix
You need to log in before you can comment on or make changes to this bug.