Closed Bug 1299606 Opened 5 years ago Closed 5 years ago

Crash in mozilla::layers::ShadowLayerForwarder::UseTextures

Categories

(Core :: Canvas: WebGL, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: mats, Unassigned)

Details

(Keywords: crash, Whiteboard: gfx-noted)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-e08c9c21-c249-40c9-8a24-56d4d2160831.
=============================================================

It seems like bug 1291296 didn't fully fix this crash signature.
The crash report above is from Nightly (51.a1) Build ID 20160830030201
which should have the fix for bug 1291296 which landed 2016-08-10:
https://hg.mozilla.org/mozilla-central/rev/d59fd1ff4bec

Stack:
mozilla::layers::ShadowLayerForwarder::UseTextures(mozilla::layers::CompositableClient*, nsTArray<mozilla::layers::CompositableForwarder::TimedTextureClient> const&)
mozilla::layers::CanvasClientSharedSurface::Updated()
mozilla::layers::ClientCanvasLayer::RenderLayer()
mozilla::layers::ClientContainerLayer::RenderLayer()
mozilla::layers::ClientContainerLayer::RenderLayer()
mozilla::layers::ClientContainerLayer::RenderLayer()
mozilla::layers::ClientLayerManager::EndTransactionInternal(...)
...

MOZ_CRASH Reason:
MOZ_RELEASE_ASSERT(t.mTextureClient->GetIPDLActor()->GetIPCChannel() == mShadowManager->GetIPCChannel())
Flags: needinfo?(nical.bugzilla)
Same issue as bug 1291296 but with the SharedSurface code path. The issue is that something producing SharedSurface objetcs is created for a given IPC channel, and then used on another channel, most likely because the tab was drag-n-dropped on another window. I don't think this can happen in an e10s process so be sure to disable e10s to reproduce.
I am not well versed into the SharedSurface code and my bug list is growing a lot faster than I can handle it, so I'll tentatively assign to Jeff who has written a good chunk of this code. Jeff, If you are too busy as well, reassign to me and I'll look into this when I have time (not in the short term I'm afraid).
Assignee: nobody → jgilbert
Flags: needinfo?(nical.bugzilla)
(In reply to Nicolas Silva [:nical] from comment #1)
> Same issue as bug 1291296 but with the SharedSurface code path. The issue is
> that something producing SharedSurface objetcs is created for a given IPC
> channel, and then used on another channel, most likely because the tab was
> drag-n-dropped on another window. I don't think this can happen in an e10s
> process so be sure to disable e10s to reproduce.
> I am not well versed into the SharedSurface code and my bug list is growing
> a lot faster than I can handle it, so I'll tentatively assign to Jeff who
> has written a good chunk of this code. Jeff, If you are too busy as well,
> reassign to me and I'll look into this when I have time (not in the short
> term I'm afraid).

I don't have time for the next two weeks.
Flags: needinfo?(milan)
Whiteboard: gfx-noted
Assignee: jgilbert → nobody
I'll work on it.
Assignee: nobody → ethlin
Flags: needinfo?(milan)
From the report, user may be using webgl page. But I cannot reproduce the problem on windows with e10s on or off. Bug 1291296 and Bug 1250954 should already fix the wrong forwarder case for CanvasClient2D and CanvasClientSharedSurface.
I don't have idea off hand since I can't reproduce. Remove assignee for now and set ni to myself.
Assignee: ethlin → nobody
Component: Graphics: Layers → Canvas: WebGL
Flags: needinfo?(ethlin)
Pushed by msreckovic@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1b451583bd65
Diagnostic, trivial patch.  Our messages were not unique. r=me
https://hg.mozilla.org/mozilla-central/rev/1b451583bd65
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Flags: needinfo?(ethlin)
You need to log in before you can comment on or make changes to this bug.