Closed Bug 1299622 Opened 5 years ago Closed 5 years ago

Tab restore in Fennec is broken when restoring two or more tabs (White / blank pages)

Categories

(Firefox for Android Graveyard :: General, defect, P1)

defect

Tracking

(fennec51+, firefox51 verified)

VERIFIED FIXED
Firefox 51
Tracking Status
fennec 51+ ---
firefox51 --- verified

People

(Reporter: rbarker, Assigned: snorp)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1) Open Fennec and create two tabs with web content.
2) Kill Fennec.
3) Restart Fennec.
4) Create new tab and try and load a new page.

Expected: page will load.
Actual: Fennec shows a white page.

Switching tabs will show content from incorrect tab.
I first encountered this yesterday (August 30) on inbound. I am now seeing this on Nightly (August 31).
tracking-fennec: --- → ?
Priority: -- → P1
Duplicate of this bug: 1299790
In the tab selection menu, I can see the correct screenshots. So I think this points at a gfx issue more than session restore?
Summary: Tab restore in Fennec is broken when restoring two or more tabs → Tab restore in Fennec is broken when restoring two or more tabs (White / blank pages)
Looks I caused this in bug 1297751. It seems to be the browser[pending] crap in the css. We weren't using that before so I'll just remove it.
Attachment #8787224 - Flags: review?(s.kaspari) → review+
Assignee: nobody → snorp
Status: NEW → ASSIGNED
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/31b4117656b2
Delete bogus browser[pending] CSS rule for Fennec r=sebastian
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/561fa3ce8c09
Delete bogus browser[pending] CSS rule for Fennec r=sebastian a=cherry-pick to fix Fennec tab restore
https://hg.mozilla.org/mozilla-central/rev/31b4117656b2
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Verified as fixed using steps in description with Samsung Galaxy Note 5(6.0.1) on Nightly(2016-09-05).
Status: RESOLVED → VERIFIED
tracking-fennec: ? → 51+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.