If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Firefox
Screen Sharing Whitelist
RESOLVED WONTFIX
a year ago
8 months ago

People

(Reporter: bitzed, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>> Vendor name
V-CUBE Inc.

>> Point of contact
mtg-v5@pj.vcube.co.jp

>> Site URLs
mtg5l.vcube.com
stg-mtg5l.vcube.com
d1mtg5l.vcube.net
*.vcube.com
*.vcube.net

>> Does the application provide users with notice and control?
Privacy Policy
http://www.vcube.com/privacy/index.html

Term of Use
http://www.vcube.com/documents/TermofService/v-cube_tos_20130430.pdf
Term of Use (Additional Services)
http://www.vcube.com/documents/TermofService/v-cube_tos_additional_jp_20130430.pdf

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes
(Reporter)

Comment 1

a year ago
If the domain must be specified as only one, please set up to this domain below.

*.vcube.com

Thank you

Comment 2

8 months ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.