bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

usps.com - Text not being displayed on <p class= >

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: David G King, Assigned: bc)

Tracking

Details

(Whiteboard: [syntax-CSS], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020306
BuildID:    2002030604

The above URL points to a FAQ area, which seems to use <p class=> to set
paragraph settings. As I'm not familiar with the class statement, this is a guess.

In any event the FAQ section headings display (e.g. General Questions), but test
below this heading is not displayed.

Reproducible: Always
Steps to Reproduce:
1. Go to URL
2. See how page is rendered


Actual Results:  Text not displayed.

Expected Results:  Expected text to display.

I've noticed that if I right-click on an area where I expect to see text, the
text appears in red behind the Mozilla pop-up menu.
No, the problem is that they use layers.  And we _do_ display the text.  It's
just white.  (try selecting it).  Basically, their page sucks.  Assigning to
evangelism.
Assignee: attinasi → bclary
Status: UNCONFIRMED → NEW
Component: Layout → US Gov
Ever confirmed: true
OS: Windows 98 → All
Product: Browser → Tech Evangelism
QA Contact: petersen → chrisn
Hardware: PC → All
Summary: Text not being displayed on <p class= > → shop.usps.com - Using <layer>
Version: other → unspecified
The page has a white background and the stylesheet it includes has:

a:link { color: rgb(255,255,255) }

So the text is just white-on-white.  You can see this by highlighting the whole
area -- the text becomes visible.

The page also has <style type = "text/css">  (with the spaces exactly like
that).  This is parsed as <style type=" text/css"> by our parser, it seems.  As
a result the <style> is ignored (since it's of type " text/css")  and hence the
text color is never changed to blue.

Over to parser.

I can't figure out why IE and Netscape do not load that stylesheet... it's
correctly imported.
Assignee: bclary → harishd
Component: US Gov → Parser
OS: All → Windows 98
Product: Tech Evangelism → Browser
QA Contact: chrisn → moied
Hardware: All → PC
Summary: shop.usps.com - Using <layer> → Text not being displayed on <p class= >
Version: unspecified → other
Er.. ignore the "I can't figure out..." part of the comment.  That was before I
noticed that they _do_ load it.
(Reporter)

Comment 4

17 years ago
Just to elaborate on the comment Boris made about Netscape and IE.

Netscape 4.79 and IE 6.0 display this page correctly.
Netscape 6.2.1 has the same problem as Mozilla build 2002030604, which indicates
to me that this isn't a regression.
OK.  I finally had a chance to investigate this at length.  The key issue is the
following line in the inline stylesheet:

    A:link         {color: "blue"; text-decoration: underline;}

This is invalid CSS -- the color name should not have quotes around it.  As a
result, Mozilla ignores the color rule and the links end up white on white. 
Taking those quotes out makes the page render fine in Mozilla.

It seems that IE and Netscape 4 are failing to follow the CSS specification
here.

To evangelism; the site need merely remove those two quotes for the page to
render fine (though they need to fix the layer issues Christopher pointed out in
order to have their little popup menus work).
Assignee: harishd → bclary
Component: Parser → US Gov
OS: Windows 98 → All
Product: Browser → Tech Evangelism
QA Contact: moied → chrisn
Hardware: PC → All
Whiteboard: [XBROWSER-CSS]
Version: other → unspecified
(Assignee)

Updated

17 years ago
Keywords: evang500
*** Bug 137840 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Summary: Text not being displayed on <p class= > → usps.com - Text not being displayed on <p class= >
[xbrowser-css] would be still valid..
Priority: -- → P3
Whiteboard: [XBROWSER-CSS] → [syntax-CSS]
(Reporter)

Comment 8

16 years ago
Site has fixed problem that I originally reported. They removed the quotes that
bz mentions in comment #5, amongst other things. Marking Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

15 years ago
tech evang june 2003 reorg
Component: US Gov → English US
(Reporter)

Comment 10

15 years ago
Site has had total redesign, verifying.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.