Closed Bug 1299805 Opened 6 years ago Closed 6 years ago

”Disable/Enable” buttons change position when pressed

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
normal

Tracking

(firefox48 unaffected, firefox49 unaffected, firefox50 affected, firefox51 affected)

RESOLVED WONTFIX
Tracking Status
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- affected
firefox51 --- affected

People

(Reporter: vtamas, Unassigned)

References

Details

Attachments

(1 file)

380 bytes, application/x-zip-compressed
Details
Attached file Archive.zip
[Note]
This is a follow-up bug for Bug 1285493

[Affected versions]:
Firefox 50.0a2 (2016-09-01)
Firefox 51.0a1 (2016-08-31)

[Affected platforms]:
Windows 10 64-bit 
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Navigate to about:debugging and install the attached webextension
3.Go to about:addons and open the add-on details page.
4.Enable and disable the add-on a few times.

[Expected results]:
The “Disable/Enable” and “Remove” buttons remain in the same position while disabling/enabling the webextension.

[Actual results]:
the “Enable/Disable” and “Remove” buttons change their position when the webextension is enabled and disabled back: http://screencast.com/t/c7ga5q2uF6x
This add-on specifies an options_ui which in this case is blank. The movement up and down of the buttons is caused by the options.html in the addon being inserted and then removed as the state changes. For most add-ons if they specify and options_ui, I'd expect that to specify and options.html as well and the UIs behaviour would make sense.

Closing as won't fix based on that and the expectation that one day, we'll rewrite this UI.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
(In reply to Andy McKay [:andym] from comment #1)
> Closing as won't fix based on that and the expectation that one day, we'll
> rewrite this UI.

For which, see bug 1212685.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.