Closed Bug 1299828 Opened 5 years ago Closed 5 years ago

some releases contain forbidden domains

Categories

(Release Engineering :: Release Requests, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1309656

People

(Reporter: bhearsum, Unassigned)

Details

Just noticed that the Firefox 12.0 release blob contains a "stage.mozilla.org" URL, which is no longer in the whitelist. It's only used for the beta channel, so probably not harmful, but maybe we should remove it?
Is this a problem right now?

Do we want a policy of deleting old blobs that contain invalid domains? That could complicate other tools if we want to use Balrog as a source of truth for releases.
(In reply to Chris AtLee [:catlee] from comment #1)
> Is this a problem right now?

Not actively, but it would be confusing if someone were to point a rule at a blob like this on a channel that points at an invalid domain.

> Do we want a policy of deleting old blobs that contain invalid domains? That
> could complicate other tools if we want to use Balrog as a source of truth
> for releases.

I definitely don't think we should delete old blobs entirely, but it may be worth removing fileUrls that simply won't work anymore.
Duping to the more detailed bug I just filed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309656
You need to log in before you can comment on or make changes to this bug.