Large gif image appears all black on 32-bit true color mode

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
P2
normal
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Matt Seitz, Assigned: dcone (gone))

Tracking

({testcase})

Trunk
Future
x86
Windows 98
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: win9x-specific?, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020310
BuildID:    2002031008

The text on page
http://www.digitalriver.com/dr/v2/ec_MAIN.Entry10?V1=338456&PN=1&SP=10023&xid=21763&DSP=&CUR=840&PGRP=0&CACHE_ID=52704
is invisible, all I see is a black background until I click-drag to highlight
the text.  Then it becomes visible.

Reproducible: Always
Steps to Reproduce:
1. Go to
http://www.digitalriver.com/dr/v2/ec_MAIN.Entry10?V1=338456&PN=1&SP=10023&xid=21763&DSP=&CUR=840&PGRP=0&CACHE_ID=52704


Actual Results:  Mozilla displays a black background with most of the software
description unreadable.

Expected Results:  Should display a white background and a full product description.

Works fine in IE 5.5.
worksforme, linux build 2002-03-10-07.

Comment 2

17 years ago
WFM 2002031008/Win2K

BODY of page sets background with incorrect URL (without correct protocol part):
//a248.e.akamai.net/f/248/5462/2h/www.digitalriver.com/v2.0-img/operations/visneer/site/back.gif
But this pretty big image is loaded and work with this page is realy slow (MSIE
is pretty fast on this page).

Comment 3

17 years ago
wfm using build 2002031008 on Win2k.
(Reporter)

Comment 4

17 years ago
wfm on a different computer using NT 4 SP6a.  So this is either just a problem
with Win 98 (and perhaps other Win 9x/ME flavors) or there is something
different about the computer I have running Win 98.

Could someone else with Win 9x/ME, preferably Win 98 First Edition, try to
reproduce this?

Comment 5

17 years ago
WFM 2002031008/Win98 SR, 4.10.2222A

Comment 6

17 years ago
I can reproduce this bug with win98 4.10.1998, and Mozilla 2002-03-11-03

Comment 7

17 years ago
Confirming in the March 11th build (2002-03-11-03) under Windows ME.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Priority: -- → P2
WFM WinXP 2002031803
Target Milestone: --- → Future

Comment 9

16 years ago
Marking works for me in the May 3th build (2002-05-03-06 1.0.0)under Windows ME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

16 years ago
Problem still occurs on my home computer with Windows 98 (First Edition,
4.10.1998), using build 2002-05-07-08, 1.0.0+.  Problem does not occur on my
office computer with Windows NT 4, using the same build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 11

16 years ago
Double-checked my video setting on my Windows ME machine was set to thousands of
colors. Changing to millions of colors reproduces the problem for me now.
Reporter, is your video setting in millions ?
(Reporter)

Comment 12

16 years ago
Yes, my Windows 98 home computer is set to "True Color (32-bit)" and shows the
problem.  However, my Windows NT 4 office computer is also set to "True Color"
and does not show the problem.  So it appears to be Windows 9x-ME specific.  

Comment 13

16 years ago
Ok, here is the large gif image form the site that appears black (in 32 bit true
color mode):

http://a248.e.akamai.net/f/248/5462/2h/www.digitalriver.com/v2.0-img/operations/visneer/site/back.gif

Comment 14

16 years ago
Reassigning to don.
Assignee: attinasi → dcone
Status: REOPENED → NEW
Keywords: testcase

Updated

16 years ago
Component: Layout → GFX Compositor

Comment 15

16 years ago
Created attachment 82676 [details]
Large gif that appears black in 32-true color mode

1500 x 4005 pixel image

Comment 16

16 years ago
Still a problem with the latest branch (2002-07-16-08 1.0.0) in 32-bit true
color mode. However, I can't reproduce with a earlier trunk build
(2002-07-11-08) in 32-bit true color. Tested under Win ME.

Updated

15 years ago
Summary: digitalriver.com - Displays black text on black background → Large gif image appears all black on 32-bit true color mode
Whiteboard: win9x-specific?

Comment 17

14 years ago
Tested with current Firefox 1.0, and no problems detected...
Marking FIXED (as it is probably fixed a long time ago...)
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → FIXED

Comment 18

14 years ago
No bug / patch specified as the fix.

-> WORKSFORME.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.