Recently Bookmarked list shows old bookmarks that got imported through Sync

RESOLVED DUPLICATE of bug 676563

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 676563
a year ago
a year ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
In profile A, create 10 bookmarks
Log in to a Firefox account
Create a new profile B
In profile B, log in to your Firefox account and start syncing

The Recently Bookmarked list doesn't show the last 5 bookmarks that were created. They are probably the last 5 synced. It looks like we are losing some timestamps.
Component: Bookmarks & History → Sync
Flags: needinfo?(markh)
Thanks Jaws - do you believe this is a recent regression? We recently landed stuff that may or may not be related :)
Flags: needinfo?(markh) → needinfo?(jaws)
I don't know. I just saw this when setting up a new machine over the previous weekend.
Flags: needinfo?(jaws)
The plot thickens! The new stuff Mark's referring to uses the current time, so that certainly seems wrong... http://searchfox.org/mozilla-central/rev/3582398bc9db5a83e25c2a8299cc780a52ad7ca8/toolkit/components/places/PlacesSyncUtils.jsm#857-859

...But the old stuff (https://hg.mozilla.org/mozilla-central/file/7bab284d7910/services/sync/modules/engines/bookmarks.js) doesn't call `setItemDateAdded` or `setItemLastModified`, either, so I'm not sure if this is a regression in 51 or something we've always done.
See Also: → bug 676563
The fix is a bit involved, so prioritizing as P3 for now.
Priority: -- → P3
This is important for Activity Stream, too, so I expect we'll come up with a plan in the coming quarter. Closing this one as a dupe because we're using bug 676563 for the product board.
Status: NEW → RESOLVED
Last Resolved: a year ago
Priority: P3 → --
Resolution: --- → DUPLICATE
Duplicate of bug: 676563
You need to log in before you can comment on or make changes to this bug.